Closed Bug 1318177 Opened 3 years ago Closed 3 years ago

LDAP user for Servo autoland

Categories

(Infrastructure & Operations :: Infrastructure: LDAP, task)

task
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1337175

People

(Reporter: gps, Unassigned)

References

Details

We need an LDAP user to support the "Servo Autoland" project. This LDAP user needs privileges to use Mercurial (hgAccountEnabled=TRUE).

The user account can be based off vcs-sync@mozilla.com or bind-autoland@mozilla.com. TBH, I'm not sure what naming convention to use and don't care too strongly about the final name. Having "servo" and "autoland" in the account name (possibly "servo-autoland") is probably a good idea though.

As for group membership, this user doesn't need to belong to any group in LDAP (other than likely "users").

We don't need a password for this user: the user only needs to SSH into hg.mozilla.org. That means we'll need to register an SSH public key at some point. I'm assuming fubar or dividehex can help me with that after the LDAP user exists.
I don't have any special ldap access; probably easiest to just include the public key here and have an ldap admin add it when creating the account.
Somehow I managed to file this bug twice.
Status: NEW → RESOLVED
Closed: 3 years ago
QA Contact: jdow
Resolution: --- → DUPLICATE
Duplicate of bug: 1337175
You need to log in before you can comment on or make changes to this bug.