WebGL1 API nullable parameter changes

RESOLVED DUPLICATE of bug 1318507

Status

()

RESOLVED DUPLICATE of bug 1318507
2 years ago
2 years ago

People

(Reporter: pchang, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox53 affected)

Details

(Whiteboard: [gfx-noted])

(Reporter)

Description

2 years ago
From this WebGL conformance commit[1] and latest WebGL 1.0 webidl[2], we need to throw exception with null input. 

[1]https://github.com/KhronosGroup/WebGL/commit/03aab58eb8fdf3151630a8c6866d93f90cca2c8e
[2]https://www.khronos.org/registry/webgl/specs/latest/1.0/webgl.idl
(Reporter)

Comment 1

2 years ago
Jeff, based on latest spec, does this introduce backward-compatibility issue for WebGL1?
Flags: needinfo?(jgilbert)
Whiteboard: [gfx-noted]
This should all be captured by the work in bug 1318507.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(jgilbert)
Resolution: --- → DUPLICATE
Duplicate of bug: 1318507
You need to log in before you can comment on or make changes to this bug.