CSS variables don't work in calc() in animation-delay

RESOLVED DUPLICATE of bug 956573

Status

()

defect
RESOLVED DUPLICATE of bug 956573
3 years ago
2 years ago

People

(Reporter: batatspamavert, Unassigned)

Tracking

({css3})

50 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID: 20161104212021

Steps to reproduce:

Created a simple css animation with a delay using calc(var(--variable) / 2)

http://codepen.io/anon/pen/yVVada


Actual results:

Animation starts without delay


Expected results:

Animation should start with a delay
(Reporter)

Updated

3 years ago
Component: Untriaged → CSS Parsing and Computation
Keywords: css3
Product: Firefox → Core
We don't currently support calc() on animation-delay.  But I think in general we do support variables inside of calc(), other than the cases in bug 1317354.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 956573
You need to log in before you can comment on or make changes to this bug.