If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

memory and display problems when using more opened windows and high resolution

RESOLVED DUPLICATE of bug 1285333

Status

()

Core
Graphics
RESOLVED DUPLICATE of bug 1285333
10 months ago
10 months ago

People

(Reporter: zetka, Unassigned, NeedInfo)

Tracking

49 Branch
Unspecified
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 months ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:49.0) Gecko/20100101 Firefox/49.0
Build ID: 20161019084923

Steps to reproduce:

I use 2560x1600 resolution display, 4GB memory 32bit W7. Using Firefox as default browser. Opening more web windows and panels (10 or more)


Actual results:

When opening more Firefox windows and the memory reaches about 80% of the system capacity, the display becomes to display errorneous, sometimes with black rectangles, sometimes the page freezes or even Firefox crashes and even after closing the pages, the memory is not correctly depleted. It is necessary to close the Firefox again and when it starts and opens the windows, it is stable for a small time, when it reaches the memory and it repeats again.


Expected results:

The Firefox has to be stable, displaying correctly independent of number of opened windows.

Comment 1

10 months ago
Could you copy here the "grahics" section from the page about:support.
Component: Untriaged → Graphics
Flags: needinfo?(zetka)
Product: Firefox → Core
(Reporter)

Comment 2

10 months ago
Grafika
Vlastnosti
Skládání	Basic
Asynchronní lupa/panning	nic
Zobrazování WebGL	Google Inc. -- ANGLE (AMD Radeon HD 6800 Series Direct3D9Ex vs_3_0 ps_3_0)
Hardwarové dekódování H264	No; Hardware video decoding disabled or blacklisted
DirectWrite	false (6.2.9200.21976)
GPU #1
Aktivní	Ano
Popis	AMD Radeon HD 6800 Series
ID prodejce	0x1002
ID zařízení	0x6738
Verze ovladače	15.301.1901.0
Datum ovladače	2-26-2016
Ovladače	aticfx32 aticfx32 aticfx32 atiumdag atidxx32 atiumdva
ID subsystému	03b01043
RAM	1024
Diagnostika
Technologie ClearType	Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 200
AzureCanvasAccelerated	0
AzureCanvasBackend	skia
AzureContentBackend	cairo
AzureFallbackCanvasBackend	cairo
Technologie ClearType	Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 200
failures	[GFX1-]: Attempt to create DrawTarget for invalid surface. Size(2540,1421) Cairo Status: 1
Decision Log
HW_COMPOSITING	
disabled by user: Disabled by pref
D3D11_COMPOSITING	
unavailable by default: Hardware compositing is disabled
D3D9_COMPOSITING	
unavailable by default: Hardware compositing is disabled
DIRECT2D	
unavailable by default: Direct2D requires Direct3D 11 compositing
D3D11_HW_ANGLE	
unavailable by default: D3D11 compositing is disabled
disabled by env: D3D11 compositing is disabled
Žurnál chyb
(#0) Error	Attempt to create DrawTarget for invalid surface. Size(2540,1421) Cairo Status: 1
(#473) Assert	Failed 2 buffer db=00000000 dw=00000000 for 0, 0, 2540, 1421
(#474) Assert	Failed 2 buffer db=00000000 dw=00000000 for 0, 0, 2540, 1421
(#475) Assert	Unknown cairo format -1
(#476) Error	Attempt to create DrawTarget for invalid surface. Size(2540,1421) Cairo Status: 1
(#477) Error	Invalid draw target(s) 00000000 and 00000000
(#478) Error	Attempt to create DrawTarget for invalid surface. Size(2540,1421) Cairo Status: 1
(#479) Error	Attempt to create DrawTarget for invalid surface. Size(2540,1421) Cairo Status: 1
(#480) Error	Attempt to create DrawTarget for invalid surface. Size(2540,1421) Cairo Status: 1
(#481) Error	Attempt to create DrawTarget for invalid surface. Size(2540,1421) Cairo Status: 1
(#482) Error	Attempt to create DrawTarget for invalid surface. Size(2540,1421) Cairo Status: 1
(#483) Error	Attempt to create DrawTarget for invalid surface. Size(2540,1421) Cairo Status: 1
(#484) Error	Attempt to create DrawTarget for invalid surface. Size(2540,1421) Cairo Status: 1
(#485) Error	Attempt to create DrawTarget for invalid surface. Size(2540,1421) Cairo Status: 1
(#486) Assert	Failed 2 buffer db=00000000 dw=00000000 for 0, 126077, 2540, 1421
(#487) Assert	Failed 2 buffer db=00000000 dw=00000000 for 0, 126077, 2540, 1421
(Reporter)

Comment 3

10 months ago
I tried different reccomendations from web to disable acceleration etc, or even the secure mode, but all time similar results. I had similar problems with Sea Monkey too. No problems with Chrome.
(Reporter)

Comment 4

10 months ago
Created attachment 8811792 [details]
typical screenshot when begining to display errorneous

Comment 5

10 months ago
Do you now if your GPU has more recent drivers?
OS: Unspecified → Windows 7
(Reporter)

Comment 6

10 months ago
I suppose they are the last ones for the HD6800, I try to update, but the were without problems.
(Reporter)

Comment 7

10 months ago
I can confirm, those are the newest.

Comment 8

10 months ago
I guess you have disabled HWA in Options > Advanced > General, no?

If yes, can you turn on HWA again (restart FF to apply).
(Reporter)

Comment 9

10 months ago
I have turned it on, it seems now, with the similar results, even that the Firefox stops to react more frequently and must be shutdowned with process manager. Still in testing.
(Reporter)

Comment 10

10 months ago
I have resetted Firefox to default, no help. I have increased the RAM to 6GB ( with PAE on 32bit), but the problem still persits. The Firefox eats RAM and dispose it not properly. The switching acceleration on or of has no influence to the problem.
(Reporter)

Comment 11

10 months ago
I am supriced than nobody react. Only for information I use 2560x1600 resolution  and 125% font size.
(Reporter)

Comment 12

10 months ago
Here are the Firefox crashes from the last few days, quite sad...:
69f08f90-f7d1-4410-a73f-abf60cf10bd8
	6.12.2016	0:55
b5018612-a113-41e6-bee0-8f03a4240ef3
	4.12.2016	13:50
b43a459a-8263-405f-b85e-9aabda16bc4f
	4.12.2016	10:32
de9fcbac-1c8b-4575-9459-10ace194cf8f
	4.12.2016	10:00
666978c3-5161-49f9-a7ae-822e98250baa
	3.12.2016	19:49
ccd70f6d-95ae-4ef7-b407-a3a362031333
	3.12.2016	19:04
bp-81f0807a-e515-4e53-8358-d83ee2161203
	3.12.2016	19:00
1a83c016-b9d3-4ab8-ac1e-3486759caef8
	1.12.2016	1:35
c1e08e70-b933-494a-abaf-6a3ce15ea018
	1.12.2016	0:27
bp-a431542a-8ec1-44e9-a047-581582161130
	1.12.2016	0:27
afe10fe9-aef2-4f02-8c77-9906060483ff
	1.12.2016	0:27
Crashes in CompositorD3D11::~CompositorD3D11()

ni?milan for triage
Flags: needinfo?(milan)
More conversation in bug 1285333 that is tracking this crash.  It does appear to be OOM situation.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 months ago
Flags: needinfo?(milan)
Resolution: --- → DUPLICATE
Duplicate of bug: 1285333
You need to log in before you can comment on or make changes to this bug.