P3P build: Setting Cookie Acceptance policy to Reject accepts cookies anyway.

VERIFIED INVALID

Status

()

Core
Networking: Cookies
VERIFIED INVALID
16 years ago
16 years ago

People

(Reporter: John Unruh, Assigned: Stephen P. Morse)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
1.) Edit>PrefsPrivacy>Cookies. Enable cookies based on privacy levels.
2.) Set all options to Reject, visit the above site, and login.
What happens: The cookies are accepted and appear in the Cookie Manager.

Comment 1

16 years ago
--> Steve
Assignee: harishd → morse
(Assignee)

Comment 2

16 years ago
It's working fine for me.

Are you using the latest build?  Did you clear out your cookie list before you 
ran this test?

tever, can you reproduce?

Comment 3

16 years ago
What's the status of this bug?  Can we confirm that it's invalid?  Please update.
(Assignee)

Comment 4

16 years ago
I just left voicemail for junruh, but here's what I believe happened.  He 
probably pulled a tree when we were still displaying the p3p dialog even though 
p3p was not part of the build.  In that case the cookie manager was ignoring 
whatever you entered into the p3p dialog.  And the only way to get p3p as part 
of the build (since it wasn't being built by default) is to go to the 
extensions/p3p directory and do an explicit nmake (or gmake as the case may be).

Later builds do not display the p3p dialog if the p3p dll is not present.  So it 
is not even possible to test this problem on a later build

In any event, I just spoke to tever and he has offered to test this out by 
explicitly building the p3p dll and seeing if the p3p choices then do what they 
are supposed to.  He'll be posting his results shorty.

As mentioned above, it worked fine when I tested it out.

Comment 5

16 years ago
I can't do a checkout today for some reason but I was able to confirm that this
is working on harishd's machine.  We set all of the privacy options to 'reject'
and went to aol.com (know to set cookies).   No cookies were set.   Marking this
as invalid.   junruh, if you still see this with the p3p.dll present please re-open.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID

Comment 6

16 years ago
verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.