Closed Bug 1318466 Opened 3 years ago Closed 3 years ago

image_builder doesn't fail when image isn't exported

Categories

(Taskcluster Graveyard :: Docker Images, defect, major)

defect
Not set
major

Tracking

(Not tracked)

RESOLVED FIXED
mozilla53

People

(Reporter: jonasfj, Assigned: jonasfj)

Details

Attachments

(1 file)

See:
https://tools.taskcluster.net/task-inspector/#UbJzgr1FShKYgCjb5orfAg/0

the image.tar.zst contains the text:
> could not find image: no such id:
> desktop1604-test:85064aaee25c36bd992c8db2388bea8ce9b50fa2de4f7e49cafc4ad9ac20ec2e

Which implies that we're not handling this error condition correctly.
Severity: normal → major
Assignee: nobody → jopsen
Status: NEW → ASSIGNED
@dustin, if you give it an r+, I'll build and publish image_builder before landing.
@gbrown,
I could reproduce the issue, but adding --fail and retry logic didn't cause any issues in:
  https://tools.taskcluster.net/task-inspector/#B4xvlQMBSC-ECbVSq_OYVA/0
Which is based on task you reportedly had issues with.

Reasoning for retrying is that this happens because:
 A) Image wasn't built successfully at all
 B) Image was built successfully, but docker was still packaging the layer when we tried to export it
    (assuming there is a race condition in the remote API)
Comment on attachment 8811955 [details]
Bug 1318466 - Fix image_builder to fail if docker socket returns 404.

https://reviewboard.mozilla.org/r/93850/#review94052

You write the most javascripty shell I've ever seen :)
Attachment #8811955 - Flags: review?(dustin) → review+
Image has been pushed to taskcluster/image_builder:1.1.0
This is now ready to autoland :)
Keywords: checkin-needed
Pushed by cbook@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7962d5889432
Fix image_builder to fail if docker socket returns 404. r=dustin
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/7962d5889432
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla53
Product: Taskcluster → Taskcluster Graveyard
You need to log in before you can comment on or make changes to this bug.