Closed Bug 1318488 Opened 3 years ago Closed 3 years ago

[mozlint] Use sys.stdout.encoding when printing formatter output

Categories

(Firefox Build System :: Lint and Formatting, defect)

defect
Not set

Tracking

(firefox53 fixed)

RESOLVED FIXED
mozilla53
Tracking Status
firefox53 --- fixed

People

(Reporter: ahal, Assigned: ahal)

References

Details

Attachments

(1 file)

Mark was hitting a UnicodeDecodeError on windows. He figured out that:
https://dxr.mozilla.org/mozilla-central/source/python/mozlint/mozlint/cli.py#105

Should be something like "sys.stdout.encoding or 'ascii'" instead. This fixed the issue for him and I verified it on Linux as well.
Thanks! I put a slightly different patch up in bug 1318496 - I'll flag Steven for review on that too, then he can choose which one he likes better and close the other as a dupe :)
Comment on attachment 8811948 [details]
Bug 1318488 - [mozlint] Use sys.stdout.encoding when printing formatter's output,

https://reviewboard.mozilla.org/r/93824/#review94660
Attachment #8811948 - Flags: review?(smacleod) → review+
Comment on attachment 8811948 [details]
Bug 1318488 - [mozlint] Use sys.stdout.encoding when printing formatter's output,

https://reviewboard.mozilla.org/r/93824/#review94660

Bah, meant to say you might want to update the comment above things a bit though before landing, as it's not as accurate anymore.
Duplicate of this bug: 1318496
Pushed by ahalberstadt@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/43556298f164
[mozlint] Use sys.stdout.encoding when printing formatter's output, r=smacleod
https://hg.mozilla.org/mozilla-central/rev/43556298f164
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla53
Product: Testing → Firefox Build System
You need to log in before you can comment on or make changes to this bug.