Resizing panes doesn't work properly when the new debugger is zoomed

RESOLVED DUPLICATE of bug 1315667

Status

DevTools
Debugger
RESOLVED DUPLICATE of bug 1315667
2 years ago
a month ago

People

(Reporter: wbamberg, Unassigned)

Tracking

Trunk

Firefox Tracking Flags

(firefox53 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8811989 [details]
debugger-resize-pane.gif

The new debugger has three main panes. You can resize them, as you'd expect, by clicking-and-dragging the lines dividing them. This works fine when the debugger is not zoomed. When it is zoomed, though (in or out), the panes change size weirdly as soon as you start dragging.

STR:
* set the devtools to a zoom factor more or less than 1
* open the debugger
* click and hold on the line between two panes
* drag

When you drag, the line jumps to a different spot.

I've attached a GIF to show what I mean.
I think this is a duplicate of bug 1315667, the inspector and debugger share the same sidebar component and the bug appears to be in that component.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1315667

Updated

a month ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.