Closed Bug 1318583 Opened 3 years ago Closed 3 years ago

Intermittent browser/components/extensions/test/browser/test-oop-extensions/browser_ext_browserAction_popup_resize.js | Window height should increase (550 >= 654) -

Categories

(WebExtensions :: Untriaged, defect)

defect
Not set

Tracking

(firefox51 unaffected, firefox52 unaffected, firefox53 fixed)

RESOLVED FIXED
mozilla53
Tracking Status
firefox51 --- unaffected
firefox52 --- unaffected
firefox53 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: kmag)

References

Details

(Keywords: intermittent-failure)

Attachments

(5 files)

Blocks: 1317101
Flags: needinfo?(kmaglione+bmo)
Yes, I'm already working on it.
Assignee: nobody → kmaglione+bmo
Flags: needinfo?(kmaglione+bmo)
Kris, do ask for help if you need it, between this and bug 1318592, we are nearing the #1 intermittent failure- glad to see you are on it already.
(In reply to Joel Maher ( :jmaher) from comment #5)
> Kris, do ask for help if you need it, between this and bug 1318592, we are
> nearing the #1 intermittent failure- glad to see you are on it already.

I have a partial fix already. It should be finished by the end of the day. The main holdup has been having to test my changes on try, since I can't reproduce the Windows issues locally.
Comment on attachment 8815525 [details]
Bug 1318583: Part 1 - Ignore fixed-width panel browser resizes that happened prior to reparenting.

https://reviewboard.mozilla.org/r/96420/#review96628
Attachment #8815525 - Flags: review?(aswan) → review+
Comment on attachment 8815526 [details]
Bug 1318583: Part 2 - Avoid races due to remote browser resizing round-trips.

https://reviewboard.mozilla.org/r/96422/#review96632
Attachment #8815526 - Flags: review?(aswan) → review+
Comment on attachment 8815527 [details]
Bug 1318583: Part 3 - Set minWidth and minHeight on non-fixed-width panel browsers.

https://reviewboard.mozilla.org/r/96424/#review96634
Attachment #8815527 - Flags: review?(aswan) → review+
Comment on attachment 8815528 [details]
Bug 1318583: Part 4 - Ensure the correct browser window is focused for tests that require it.

https://reviewboard.mozilla.org/r/96426/#review96680

::: browser/components/extensions/test/browser/browser_ext_omnibox.js:197
(Diff revision 1)
>    }
>  
>    function* testSuggestions(info) {
>      extension.sendMessage("set-synchronous", {synchronous: false});
>  
> +    /* eslint-disable mozilla/no-cpows-in-tests */

Matt landed this in a separate patch already, you can remove this.
Attachment #8815528 - Flags: review?(aswan) → review+
Comment on attachment 8815529 [details]
Bug 1318583: Part 5 - Re-enable OOP tests that were disabled due to focus issues.

https://reviewboard.mozilla.org/r/96428/#review96682
Attachment #8815529 - Flags: review?(aswan) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/53a2e609bc8941ee98f679f1576e30e207b53d2b
Bug 1318583: Part 1 - Ignore fixed-width panel browser resizes that happened prior to reparenting. r=aswan

https://hg.mozilla.org/integration/mozilla-inbound/rev/8db368bd5ecbc1159e4a4675f5c368f56a090df3
Bug 1318583: Part 2 - Avoid races due to remote browser resizing round-trips. r=aswan

https://hg.mozilla.org/integration/mozilla-inbound/rev/2bd028b1ed5f8ce717bb620a0ca7a1e4f6be6670
Bug 1318583: Part 3 - Set minWidth and minHeight on non-fixed-width panel browsers. r=aswan

https://hg.mozilla.org/integration/mozilla-inbound/rev/c258d5040f12098bfcc9c69a5215e14ffdcd79d6
Bug 1318583: Part 4 - Ensure the correct browser window is focused for tests that require it. r=aswan

https://hg.mozilla.org/integration/mozilla-inbound/rev/fd396493d0409b1f35890c7047188deca5df13fb
Bug 1318583: Part 5 - Re-enable OOP tests that were disabled due to focus issues. r=aswan
Duplicate of this bug: 1318592
Duplicate of this bug: 1315436
Duplicate of this bug: 1319651
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.