URL highlight ends at the "|" in Mail

RESOLVED INVALID

Status

SeaMonkey
MailNews: Message Display
RESOLVED INVALID
16 years ago
14 years ago

People

(Reporter: Benjamin Mucci, Assigned: BenB)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:0.9.9+) Gecko/20020313
BuildID:    2002031303

Problem with highlight and the caracter "|"

http://www.register.com/append_note_u.cgi?1|xxxxxx|CO1&ref=xxxxxxxx
                                           ^
                                           |
                           highlight ends here

Reproducible: Always

Comment 1

16 years ago
original: http://www.register.com/append_note_u.cgi?1|xxxxxx|CO1&ref=xxxxxxxx

BenB, this looks really bad with an HTML message viewed as plain text, you get:

http://www.register.com/append_note_u.cgi?1| xxxxxx|CO1&ref=xxxxxxxx
<http://www.register.com/append_note_u.cgi?1%7Cxxxxxx%7CCO1&ref=xxxxxxxx>

(OK, I put in the space to make it display right in Bugzilla)

/me idly wonders if www.register.com accepts %7C
Assignee: sspitzer → ben.bucksch
(Assignee)

Comment 2

16 years ago
INVALID. The URL is invalid; "|" is not allowed in URLs.

URLs delimited by whitespace are recognized using heurisms only anyways. URLs in
<> are recognized better (but not sure about this case, as "|" is invalid).

In the case Neil mentions, I see even less of a problem, as the user does have a
clickable URL.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

16 years ago
This bug should be move to Envangelis in that case... Take a look at the
register.com site they use "|" in every URL.

Also Communicator 4.7 handles the | in mail message why not Moz!?
(Assignee)

Comment 4

16 years ago
> This bug should be move to Envangelis in that case... Take a look at the
> register.com site they use "|" in every URL.

Please file a new bug in that case.

> Also Communicator 4.7 handles the | in mail message why not Moz!?

Because Moz is better?
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.