Strings are not properly counted in RDM while search with Find Option

VERIFIED FIXED in Firefox 52

Status

defect
P1
normal
VERIFIED FIXED
3 years ago
Last year

People

(Reporter: ciprian_georgiu, Assigned: jryans)

Tracking

({regression})

52 Branch
Firefox 53
Dependency tree / graph

Firefox Tracking Flags

(firefox50 unaffected, firefox51 unaffected, firefox52 verified, firefox53 verified)

Details

(Whiteboard: [rdm-v2])

Attachments

(1 attachment)

[Affected versions]:
- latest Aurora 52.0a2
- latest Nightly 53.0a1

[Affected platforms]:
- Windows 7 x86, x64
- Mac OS X 10.11.6
- Ubuntu 16.04 x86

[Steps to reproduce]:
1. Start Firefox
2. Go to: https://goo.gl/N7C964
3. Enable RDM tool (Ctr/Cmd+Shift+M) and search for "W" with find option.
4. Close RDM tool
5. Enable RDM again an search for the same letter "W" from step 3.

[Expected result]:
- The strings are shown correctly in the matches option.

[Actual result]:
- The string are not correctly shown (counted) in matches.

[Regression range]:
- This is a regression as it is not reproducible on Nightly 47.0a1 (20160222030212). I will follow up with more info ASAP.

[Additional notes]:
- after step 3 the strings are correctly matched but after step 5 they are not.
QA Whiteboard: [qe-rdm]
Summary: String are not properly counted in RDM while search with Find Option → Strings are not properly counted in RDM while search with Find Option
I used mozregression to find a regression range here, although, I'm not entirely sure if this is very accurate. I encountered some issues when tried to bisect this bug. You can see here the results:

https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=68c0b7d6f16ce5bb023e08050102b5f2fe4aacd8&tochange=8fc46323cee61bddc4c38701d6020379bba5774a

Based on the pushlog, looks like the following bug has the changes which introduced the regression: Bug  Bug 1240594. If you have any questions please let me know.
Keywords: regression
Bug 1240896 seems like a much more likely of a culprit given that regression range.
Flags: needinfo?(jryans)
Assignee

Comment 3

3 years ago
Yes, I would guess something like bug 1240896 is probably right.

However, I can't seem to reproduce the issue.  I think I am always seeing the correct count.

Ciprian, could you make a screencast of your test?
Flags: needinfo?(jryans) → needinfo?(ciprian.georgiu)
I forgot to add that you need to search through strings with "Find the previous occurrence of the phrases" and "Find the next occurrence of the phrases" buttons in order to reproduce it. 

As you can see in the screencast when I first enter into RDM and search through strings it displays 1 of 52 matches then goes to 2 of 52 matches as I click on the next button an so on.

But, when I close the RDM and open it again, then search for a string, it shows 7 of 52 matches even if I click on the next or previous button. Also, if I search for another string I can see the exact numbers (seems that strings are no longer counted). Hope it's more clear now.

Does this info helped you J.Ryan, to reproduce this issue? you can see here the screencast: https://goo.gl/YRnkys.
Flags: needinfo?(ciprian.georgiu)
Assignee

Comment 5

3 years ago
Great, I can reproduce the issue, thanks!
Priority: -- → P3
Assignee

Comment 6

3 years ago
After a high level investigation, it looks like the find bar gets disconnected from the browser, so it's no longer receiving status updates correctly.
Assignee

Updated

3 years ago
Assignee: nobody → jryans
Status: NEW → ASSIGNED
Flags: qe-verify+
Priority: P3 → P1
QA Contact: mihai.boldan
Whiteboard: [multiviewport] [reserve-rdm] → [rdm-v2]
Comment hidden (mozreview-request)

Comment 9

3 years ago
mozreview-review
Comment on attachment 8815953 [details]
Bug 1318675 - Reconnect find bar when toggling RDM.

https://reviewboard.mozilla.org/r/96722/#review97118

Search count looks correct now, but the string in the search field gets reseted on RDM toggle?
Attachment #8815953 - Flags: review?(poirot.alex) → review+
Assignee

Comment 10

3 years ago
mozreview-review-reply
Comment on attachment 8815953 [details]
Bug 1318675 - Reconnect find bar when toggling RDM.

https://reviewboard.mozilla.org/r/96722/#review97118

Good call, I sprinkled some more tweaks to preserve the search string too.
Comment hidden (mozreview-request)

Comment 12

3 years ago
Pushed by jryans@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/606ef5d2c9d2
Reconnect find bar when toggling RDM. r=ochameau

Comment 13

3 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/606ef5d2c9d2
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 53
Assignee

Comment 14

3 years ago
Comment on attachment 8815953 [details]
Bug 1318675 - Reconnect find bar when toggling RDM.

Approval Request Comment
[Feature/Bug causing the regression]: New Responsive Design Mode (first enabled in 52) doesn't connect the find bar correctly
[User impact if declined]: Find bar counts won't update properly
[Is this code covered by automated tests?]: No, manually tested
[Has the fix been verified in Nightly?]: Tested locally
[Needs manual test from QE? If yes, steps to reproduce]: Not required, but QE can test using the STR in the bug
[List of other uplifts needed for the feature/fix]: None
[Is the change risky?]: No
[Why is the change risky/not risky?]: Only affects UI within RDM
[String changes made/needed]: None
Attachment #8815953 - Flags: approval-mozilla-aurora?
I managed to reproduce this issue on Firefox 53.0a1 (2016-11-17), under Windows 10x64.
The issue is no longer reproducible on Firefox 53.0a1 (2016-12-04).
I'm marking this issue Verified Fixed, but I'm not removing the qe-verify + flag, in order to see if this fix will be applied to 52.0a2 build as well.

Tests were performed under Windows 10x64, Mac OS X 10.9.5, Ubuntu 16.04x64
Status: RESOLVED → VERIFIED
Comment on attachment 8815953 [details]
Bug 1318675 - Reconnect find bar when toggling RDM.

fix for devtools RDM, take in aurora52
Attachment #8815953 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
I have reproduced this bug with Nightly 53.0a1 (2016-11-18) (64-bit) on Windows 7 , 64 Bit ! 

This bug's fix is verified with latest Developer Edition (Aurora)

Build ID   :  20161228004005
User Agent :  Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0
[bugday-20161228]
Thanks Maruf for helping us.
I've also tested this issue on Firefox 52.0a2 (2016-12-28), under Mac OS X 10.11.6 and under Ubuntu 14.04x64 OSs and the issue is no longer reproducible.
Flags: qe-verify+

Updated

Last year
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.