Closed Bug 1318678 Opened 3 years ago Closed 3 years ago

Fix link error in TestBlockingProcess when Bug 1317638 has been landed.

Categories

(Core :: XPCOM, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla53
Tracking Status
firefox53 --- fixed

People

(Reporter: JamesCheng, Assigned: JamesCheng)

References

Details

Attachments

(1 file)

After bug 1317638 landed, some mac developer told me that this bug will cause link error like

16:23.39 TestBlockingProcess
16:23.59 libpkcs11testmodule.dylib
16:23.75 libtlsserver.a.desc
16:24.09 TestPRIntN
16:24.75 Executing: /usr/bin/clang++ -std=gnu++11 -Qunused-arguments -Qunused-arguments -Wall -Wc++11-compat -Wempty-body -Wignored-qualifiers -Woverloaded-virtual -Wpointer-arith -Wsign-compare -Wtype-limits -Wunreachable-code -Wwrite-strings -Wno-invalid-offsetof -Wclass-varargs -Wloop-analysis -Wc++11-compat-pedantic -Wc++14-compat -Wc++14-compat-pedantic -Wc++1z-compat -Wimplicit-fallthrough -Wstring-conversion -Wthread-safety -Wno-inline-new-delete -Wno-error=deprecated-declarations -Wno-error=array-bounds -Wno-unknown-warning-option -Wno-return-type-c-linkage -fno-exceptions -fno-strict-aliasing -stdlib=libc++ -fno-rtti -fno-exceptions -fno-math-errno -pthread -pipe -g -fno-omit-frame-pointer -o TestBlockingProcess -Wl,-filelist,/Volumes/workplace/minbound/obj-x86_64-apple-darwin16.0.0/xpcom/tests/tmp6Yxp0q.list -framework Cocoa -lobjc -framework AudioToolbox -framework ExceptionHandling -Wl,-executable_path,/Volumes/workplace/minbound/obj-x86_64-apple-darwin16.0.0/dist/bin -fcolor-diagnostics
16:24.75 /Volumes/workplace/minbound/obj-x86_64-apple-darwin16.0.0/xpcom/tests/tmp6Yxp0q.list:
16:24.75     TestBlockingProcess.o
16:24.75
16:24.75 Undefined symbols for architecture x86_64:
16:24.76   "mozilla::Unused", referenced from:
16:24.76       _main in TestBlockingProcess.o
16:24.76 ld: symbol(s) not found for architecture x86_64
16:24.76 clang: error: linker command failed with exit code 1 (use -v to see invocation)
16:24.78 make[5]: *** [TestBlockingProcess] Error 1
16:24.78 make[4]: *** [xpcom/tests/target] Error 2
16:24.78 make[4]: *** Waiting for unfinished jobs....
16:28.85 libhost_breakpad_common_s.a
16:28.89 libmedia_mtransport_test.a.desc


which used mozilla::Unused but the symbol is in Unused.cpp in static lib libmfbt...

The weird thing is that I cannot reproduce in my local Ubuntu machine and Treeherder either(so it's landed).  

This bug is a quick fix for that...
Attachment #8812203 - Flags: review?(erahm)
Comment on attachment 8812203 [details]
Bug 1318678 - Fix link error for Bug 1317638.

https://reviewboard.mozilla.org/r/94034/#review94206

::: xpcom/tests/moz.build:55
(Diff revision 1)
>  RESOURCE_FILES += [
>      'test.properties',
>  ]
> +
> +USE_LIBS += [
> +    'mfbt',

You want mozglue here.  I'll just land a simple fix for this since this is breaking mine and others' builds.
Attachment #8812203 - Flags: review-
Thanks,
But I don't understand why I need mozglue here?

and do you have any idea why I cannot reproduce on ubuntu or try build....

Thank you!
Flags: needinfo?(ehsan)
Pushed by eakhgari@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/67bdd259eda2
Fix linking TestBlockingProgram on OSX after bug 1317638 landed
Attachment #8812203 - Flags: review?(erahm)
(In reply to James Cheng[:JamesCheng] from comment #3)
> Thanks,
> But I don't understand why I need mozglue here?

erahm actually suggested on IRC to use mfbt instead of mozglue.  I'm not really sure what the difference between the two is these days.

> and do you have any idea why I cannot reproduce on ubuntu or try build....

For whatever reason it seems that this only occurs in OSX.  I'm not sure why unfortunately.
Flags: needinfo?(ehsan)
I can reproduce on Windows 10 and VS2015u3 in a clobber build
Summary: Fix link error when Bug 1317638 has been landed. → Fix link error in TestBlockingProcess when Bug 1317638 has been landed.
https://hg.mozilla.org/mozilla-central/rev/67bdd259eda2
https://hg.mozilla.org/mozilla-central/rev/9bcdca0ed348
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla53
You need to log in before you can comment on or make changes to this bug.