JS Component Loader needs to report uncaught exceptions

VERIFIED DUPLICATE of bug 24688

Status

()

defect
P3
normal
VERIFIED DUPLICATE of bug 24688
20 years ago
19 years ago

People

(Reporter: shaver, Assigned: mike+mozilla)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

NSGetModule and various nsIModule calls can result in exceptions being thrown
through or by the JS component's code.  We need to report them somewhere, rather
than just swallowing them.
Status: NEW → ASSIGNED
QA Contact: cbegle → shaver
Target Milestone: M11
Accepting, setting to M11, getting off cmb's radar (sorry; it won't let me
assign a QA Contact when I create a new bug).
Target Milestone: M11 → M12
m12
shaver deftly dodges the oncoming M12 train.  He will catch his breath and leap
aboard the M13 one as soon as it starts boarding.
Target Milestone: M13 → M14
M13 is about to sail, and I don't think anyone but me actually cares about this.
=)
How come this is still M14? M14 is already out!
mccabe is the error-reporting god.
Assignee: shaver → mccabe
Status: ASSIGNED → NEW
Mass moving old milestone bugs to M16
Target Milestone: M14 → M16
M16 has been out for a while now, these bugs target milestones need to be 
updated.
Marking as dup of 24688

*** This bug has been marked as a duplicate of 24688 ***
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
Verified dupe.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.