Input case sensitivity attribute (support WHATWG feature suggestion)

RESOLVED WONTFIX

Status

()

Core
DOM: Core & HTML
--
enhancement
RESOLVED WONTFIX
a year ago
a year ago

People

(Reporter: Vincent MONIER, Unassigned)

Tracking

47 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

a year ago
Created attachment 8812232 [details]
Sample of displaying

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID: 20160623154057

Steps to reproduce:

I would like Firefox' member opinion on the WHATWG feature request I made about case-sensitivity for input fields: https://github.com/whatwg/html/issues/2064


Actual results:

Reading some articles to make websites better, I saw that opquat suggest websites to show a hint to users when case lock is ON while filling a case-sensitive input. This makes sense as a lot of fields could be case sensitive: password, username, email, URL, hostnames (and maybe some others). But this also means that every website has to implement it in their own way (no standard user experience, no device-independant definition).

So for now, every website must implement the hint about case sensitivity lock in their own way (assuming that javascript can detect such behavior).


Expected results:

I think that WHATWG should add a way to tell that an input is case-sensitive. I also think that adding a simple boolean attribute for that (like <input casesensitive="casesensitive"/>) is too narrow and specific. So I suggest to add an attribute dedicated to "sensitivity" in general, allowing keywords like "case" (this input is case sensitive) or "accent" (a and à will be considered as different) or maybe "trim" (spaces at the start and end of the fields must be kept, useful when your password is auto-generated).

The hint could then be the same as for form validation: a simple tooltip containing a Firefox-defined warning text saying "This input is case sensitive" (see attached file). This would improve user experience (maybe by applying case-sensitivity by default on all password fields, so it impacts all existing websites?) and provide a standard way of telling user how an input behave.

I've opened the request on their github, but I would like to know Firefox's team opinion and get you support (or not) on the opened issue https://github.com/whatwg/html/issues/2064
(Reporter)

Comment 1

a year ago
And this support-and-opinion asking ticket follows the 3rd point of WHATWG process description ( https://wiki.whatwg.org/wiki/FAQ#Is_there_a_process_for_adding_new_features_to_a_specification.3F ):

"Get more people involved. Ask fellow Web developers about their opinions (but remind them of step 1 above [= don't think about how this should be implemented])."

Updated

a year ago
Severity: normal → enhancement
Component: Untriaged → DOM: Core & HTML
OS: Unspecified → All
Product: Firefox → Core
Hardware: Unspecified → All
I agree with what @domenic said in the github issue.
We already have a bug open to do implement a warning for password fields: bug 259059.
I guess we could warn for ordinary text fields as well on focus, and then remove
the warning once the user starts typing (because then it should obvious).
(Reporter)

Comment 3

a year ago
In fact, I agree too because it would not be as powerful as a new attribute, but it would be way sufficient for the vast majority of use cases (passwords are usually case sensitive, but usernames are usually not, but they're right: I'm now unsure about how UX would be improved by knowing the username is not case sensitive).
According to the conclusion https://github.com/whatwg/html/issues/2064  going to close this as wontfix, but let's move the UI discussion to bug 259059. Thanks for the discussion!
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.