reader view button appears in all the pages

RESOLVED DUPLICATE of bug 1320603

Status

()

Firefox for Android
Reader View
P1
normal
RESOLVED DUPLICATE of bug 1320603
a year ago
11 months ago

People

(Reporter: prasanthp96, Assigned: walkingice)

Tracking

53 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(fennec+)

Details

Attachments

(2 attachments)

(Reporter)

Description

a year ago
Created attachment 8812293 [details]
reader view button in url

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20161010225941

Steps to reproduce:

1.Launch the firefox
2.Viewed the home page
3.Went to about: page
4.Went to many websites


Actual results:

The url contained the reader view button ( Nothing happened on clicking the button )


Expected results:

The url must not have the reader view button
(Reporter)

Updated

a year ago
OS: Unspecified → Android
Hardware: Unspecified → ARM
Hello and thanks for report!

I couldn't reproduce the issue that you describe following your steps to reproduce. What device and Android did you use? And at step 4, what websites did you visit? If you clear your data from Settings -> Clear Private Data you still see the issue?
Flags: needinfo?(prasanthmani2010)
Every now and then I get into a state (Nightly) where this happens. It even gets worse and there are multiple reader view buttons in the URL bar. None of them does anything when clicked. So far I thought this was a side effect when enabling "Custom Tabs" support.
Created attachment 8812798 [details]
Screenshot_20161101-101354.png
Status: UNCONFIRMED → NEW
tracking-fennec: --- → ?
Ever confirmed: true
Priority: -- → P1
@prasanthp96: Did you enable custom tabs support (Settings -> Advanced -> Experimental Features)?

I can reproduce it like this:
* Enable custom tabs support and set Nightly as your default browser
* Open an article in the browser (The reader mode icon should appear)
* Switch to a third-party app that uses custom tabs (e.g. Yahnac)
* Open a custom tab that opens also an article
* Switch back to the browser

-> There are now two reader mode icons in the URL bar. One of them is now permanent and doesn't do anything when clicked.
Duplicate of this bug: 1318753
Following the steps from comment 4 I am able to reproduce this. Tested with Nexus 5 (Android 6.0.1).
Flags: needinfo?(prasanthmani2010)
Assignee: nobody → walkingice0204
Status: NEW → ASSIGNED
tracking-fennec: ? → +
(Assignee)

Comment 7

a year ago
In PageActionLayout, Reader drawable will be added/removed depends upon events *PageActions:Add* or *PageActions/Remove*.

Usually when we browsing web pages, Gecko fires events properly.

If we follow comment 4 to reproduce, in step 2 the Reader-mode-icon appears, mPageActionList has one item. That is correct.

(If now we press HOME key and switch back to Fennec, Gecko will fire Remove and Add events to recreate icon again)

In step 5, Gecko will fire a event to remove Reader-mode-icon, but event's id does not match existing one(created from step 2). Then it doesn't remove anything, then we have icon-leak.

Jim, do you have any idea of that wrong id?
Flags: needinfo?(nchen)
The patch in bug 1320603 changes "PageActions:Add" and "PageActions/Remove" from using the per-GeckoView EventDispatcher to using the global EventDispatcher. Can you see if that patch fixes this bug as well?
Flags: needinfo?(nchen)
(Assignee)

Comment 9

a year ago
YES. It fixed this issue. After applying that patch, PageActionLayout got a correct removing-event for Reader icon.
(Assignee)

Comment 10

11 months ago
This bug cause by unexpected events, and it should be fixed by bug 1320603
Status: ASSIGNED → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1320603
You need to log in before you can comment on or make changes to this bug.