If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Firefox hangs when opening the dev tools

RESOLVED WORKSFORME

Status

()

Firefox
Developer Tools: Inspector
P3
major
RESOLVED WORKSFORME
10 months ago
8 months ago

People

(Reporter: arun ganeshan, Unassigned, NeedInfo)

Tracking

50 Branch
Unspecified
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 months ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/54.0.2840.98 Safari/537.36

Steps to reproduce:

When i am trying to open my dev tools and most of the time the firefox hangs with an error


TypeError: wc is undefined: trackSelection/</</<@resource://gre/modules/commonjs/toolkit/loader.js -> resource://react-devtools/main/trackSelection.js:39:9
emit@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/shared/event-emitter.js:191:13
Selection.prototype.setNodeFront@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/client/framework/selection.js:186:5
nsContextMenu.prototype.inspectNode/</<@chrome://browser/content/nsContextMenu.js:600:9
Handler.prototype.process@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:937:23
this.PromiseWalker.walkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:816:7
this.PromiseWalker.scheduleWalkerLoop/<@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:750:11




Actual results:

The firefox hangs and i have to close my browser and restart it again
Firefox version : 50
OS mac 


Expected results:

should work
(Reporter)

Updated

10 months ago
Whiteboard: dev-tool error

Comment 1

10 months ago
Is it reproducible with a fresh profile?
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
Component: Untriaged → Developer Tools
Flags: needinfo?(arungane)
OS: Unspecified → Mac OS X
Summary: wc object is undefined → Firefox hangs when opening the dev tools
Whiteboard: dev-tool error

Comment 2

10 months ago
bug 1222586 have the same error info and fixed in ver 51.
Severity: normal → major

Comment 3

10 months ago
arun, can you test FF51?
https://www.mozilla.org/en-US/firefox/beta/all/
(Reporter)

Comment 4

10 months ago
I tried it out don't see that error now .. Thank you
Flags: needinfo?(arungane)
(Reporter)

Comment 5

10 months ago
Sorry ... I can see it again now .. It happens when i am navigating from debug to console tab on the dev tools..

ARUNGANE-M-F0S5:~ arungane$ $FIREFOX_EXEC
console.error: 
  TypeError: wc is undefined: trackSelection/</</<@resource://gre/modules/commonjs/toolkit/loader.js -> resource://react-devtools/main/trackSelection.js:39:9
emit@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/shared/event-emitter.js:191:13
Selection.prototype.setNodeFront@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/client/framework/selection.js:163:5
nsContextMenu.prototype.inspectNode/</<@chrome://browser/content/nsContextMenu.js:578:9
Handler.prototype.process@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:937:23
this.PromiseWalker.walkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:816:7
this.PromiseWalker.scheduleWalkerLoop/<@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:750:11

TypeError: wc is undefined: trackSelection/</</<@resource://gre/modules/commonjs/toolkit/loader.js -> resource://react-devtools/main/trackSelection.js:39:9
emit@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/shared/event-emitter.js:191:13
Selection.prototype.setNodeFront@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/client/framework/selection.js:163:5
nsContextMenu.prototype.inspectNode/</<@chrome://browser/content/nsContextMenu.js:578:9
Handler.prototype.process@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:937:23
this.PromiseWalker.walkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:816:7
this.PromiseWalker.scheduleWalkerLoop/<@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:750:11

console.error: 
  Message: Error: findCssSelector received element not inside document
  Stack:
    CssLogic.findCssSelector@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/server/css-logic.js:737:11
exports.NodeActor<.getUniqueSelector@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/server/actors/inspector.js:616:12
generateRequestHandlers/</handler@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/shared/protocol.js:1042:19
onPacket@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/server/main.js:1748:15
ChildDebuggerTransport.prototype.receiveMessage@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/shared/transport/transport.js:761:7

CssLogic.findCssSelector@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/server/css-logic.js:737:11
exports.NodeActor<.getUniqueSelector@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/server/actors/inspector.js:616:12
generateRequestHandlers/</handler@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/shared/protocol.js:1042:19
onPacket@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/server/main.js:1748:15
ChildDebuggerTransport.prototype.receiveMessage@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/shared/transport/transport.js:761:7
console.error: 
  Protocol error (unknownError): findCssSelector received element not inside document
(Reporter)

Comment 6

10 months ago
"Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:51.0) Gecko/20100101 Firefox/51.0"
Flags: needinfo?(arungane)

Comment 7

10 months ago
(In reply to arun ganeshan from comment #5)
> Sorry ... I can see it again now .. It happens when i am navigating from
> debug to console tab on the dev tools..

Does it appear on every page to debug? Do you have more "detailed" steps to reproduce?
(Reporter)

Comment 8

10 months ago
I think it happen when you are on 127.0.0.1 and not on domains...
Component: Developer Tools → Developer Tools: Inspector
arun: I can't reproduce the issue here. In your stacktrace lots of errors come from "resource://react-devtools/main/trackSelection.js" which means you are testing with the react devtools addon installed. Even after installing it I can't get the devtools to crash as you described.

Can you:
- try with a clean profile (and no addon installed), see comment 1
- give us more detailed steps to reproduce

Otherwise, the bug is not actionable and will be closed.
Priority: -- → P3
Closing the bug as unreproducible. 
@arun : feel free to reopen if you have more detailed STRs.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.