ubuntu 16.04 image uses wrong copy of "run-wizard" binary in one-click-loaners

RESOLVED FIXED in mozilla53

Status

defect
RESOLVED FIXED
3 years ago
Last year

People

(Reporter: jmaher, Assigned: ahal)

Tracking

unspecified
mozilla53

Details

Attachments

(1 attachment)

I am trying to debug a reftest failure which is on ubuntu 16.04.  I can do the run-wizard properly, but there is no mach command- and cut/paste doesn't work.

here is the task:
https://tools.taskcluster.net/task-inspector/#cseBmHkrQWSAMVliWfp6BA/0

I ran option 2 on run-wizard.
Can you describe what you did?  Mach is part of the source checkout, so it's not something that needs to be installed..
Assignee: nobody → jopsen
There is no source-checkout for 99% of test jobs :).

There is behind the scenes magic to get an out-of-tree mach environment working for these types of jobs.. I'm not sure why it's not working, but this isn't the taskcluster team's responsibility.
Assignee: jopsen → ahalberstadt
Status: NEW → ASSIGNED
Component: Tools → General
Product: Taskcluster → Testing
I got a loaner and selecting option 2 (setup the task) from the root checkout.  When that finished, I did:
* chown -R worker workspace
* chgrp -R worker workspace

Then I went to the interactive display and opened up a terminal, |mach| was not available.  On a 12.04 machine this is the workflow that works for me.

this was a reftest task, not sure if reftest is different from mochitest where I was using a 12.04 machine.
Huh, the 16.04 image uses a separate "run-wizard" binary for some reason:
https://dxr.mozilla.org/mozilla-central/source/testing/docker/desktop1604-test/bin/run-wizard

This should be using the one here:
https://dxr.mozilla.org/mozilla-central/source/taskcluster/scripts/tester/run-wizard

I believe this is also the reason you saw bug 1319117.
Summary: one click loaner on ubuntu 16.04 doesn't seem to have mach available → ubuntu 16.04 image uses wrong copy of "run-wizard" binary in one-click-loaners
Duplicate of this bug: 1319117
Component: General → Docker Images
Product: Testing → Taskcluster
Comment on attachment 8813349 [details]
Bug 1318841 - Ensure desktop1604-test docker image downloads the run-wizard binary from vcs,

https://reviewboard.mozilla.org/r/94770/#review94992

this is great, please be careful as image generation is usually quite flaky- I think it would be best to ensure this final image is generated and validated on try, so that when landing on autoland we are using an already built docker image.
Attachment #8813349 - Flags: review?(jmaher) → review+
Comment on attachment 8813349 [details]
Bug 1318841 - Ensure desktop1604-test docker image downloads the run-wizard binary from vcs,

https://reviewboard.mozilla.org/r/94770/#review94992

This is tested here:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=f045fca70cc610d24f8f457f0807027cf5c5a700

Is that what you meant? The patch pushed there is the same as the one here.
yes, this sounds good!
Pushed by ahalberstadt@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/59e448d0eba8
Ensure desktop1604-test docker image downloads the run-wizard binary from vcs, r=jmaher
https://hg.mozilla.org/mozilla-central/rev/59e448d0eba8
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla53
Product: Taskcluster → Taskcluster Graveyard
You need to log in before you can comment on or make changes to this bug.