Crash in mozilla::dom::VideoDecoderManagerParent::RecvReadback

RESOLVED FIXED in Firefox 53

Status

()

Core
Audio/Video: Playback
--
critical
RESOLVED FIXED
a year ago
11 months ago

People

(Reporter: kanru, Assigned: mattwoodrow)

Tracking

({crash, regression})

52 Branch
mozilla53
Unspecified
Windows 7
crash, regression
Points:
---

Firefox Tracking Flags

(firefox50 unaffected, firefox51 unaffected, firefox52 disabled, firefox53 fixed)

Details

(crash signature)

Attachments

(1 attachment)

(Reporter)

Description

a year ago
This bug was filed from the Socorro interface and is 
report bp-aabdfb71-73d0-45ea-b48e-289652161119.
=============================================================

Looks like we should null check |source| not |image|
Flags: needinfo?(matt.woodrow)
(Assignee)

Comment 1

a year ago
Created attachment 8812636 [details] [diff] [review]
readback-crash
Assignee: nobody → matt.woodrow
Flags: needinfo?(matt.woodrow)
Attachment #8812636 - Flags: review?(dvander)
Attachment #8812636 - Flags: review?(dvander) → review+

Comment 2

a year ago
Pushed by mwoodrow@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/a64eaf74ef8b
Null check the right pointer in RecvReadback. r=dvander

Comment 3

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/a64eaf74ef8b
Status: NEW → RESOLVED
Last Resolved: a year ago
status-firefox53: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla53
status-firefox50: --- → unaffected
status-firefox51: --- → unaffected
status-firefox52: --- → disabled
Version: Trunk → 52 Branch
You need to log in before you can comment on or make changes to this bug.