Contents of particular "tagesschau.de" RSS feed shown as source view

RESOLVED DUPLICATE of bug 1316256

Status

SeaMonkey
Feed Discovery and Preview
RESOLVED DUPLICATE of bug 1316256
2 years ago
2 years ago

People

(Reporter: Rainer Bielefeld, Unassigned)

Tracking

SeaMonkey 2.49 Branch
Unspecified
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [easyconfirm], URL)

Attachments

(3 attachments)

(Reporter)

Description

2 years ago
Created attachment 8812452 [details]
screenshot of contents: sourceco view

Steps how to reproduce with Server-Installation of  unofficial (by FRG) en-US SeaMonkey 2.49a2  (NT 6.1; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0 Build 20161118170316  (Default Classic Theme) on German WIN7 64bit:

1. With Browser visit <http://www.tagesschau.de/download/xml/>
2. Click link <http://www.tagesschau.de/xml/rss2> to subscribe news feed
3. in MailNews Client (Folder Pane) click 
   "tagesschaude - Die Nachrichten der ARD" and select 
    "Trauer um Theatermacher Heribert Sasse" (or any other) in 
     Thread Pane
   Expected: HRML Page view 
   Actual: Source code shown

Web page you reach by link "Website" in header area looks normal.
(Reporter)

Comment 1

2 years ago
a) NOT reproducible with same Build on WIN10 (with rather fresh profile)
b) NOT reproducible with SeaMonkey from original report with newly created 
   User Profile
(Reporter)

Comment 2

2 years ago
c) STILL REPRODUCIBLE with SM and User Profile from original report in Safe Mode
   with all Add-ons disabled.
Created attachment 8812454 [details]
Capture.PNG

Hmm works for me. Fresh build but I see no patches which could have fixed this.

Built from http://hg.mozilla.org/releases/comm-aurora//rev/2dcdcf8f07d948e33e8429f50f8632f1b222e9ab

Build identifier: 20161119133235

I am seeing NoScript errors in the log. 

If you want I can refresh my build for you.
Confirmed in a new profile. Must be a setting somewhere.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 5

2 years ago
d) when I see the problem I get in Error console:
   Timestamp: 19.11.2016 18:29:43
   Error: ReferenceError: getivw is not defined
   Source File: http://www.tagesschau.de/ausland/malaysia-demonstration-101.html
   Line: 1058
(Reporter)

Comment 6

2 years ago
e) Already REPRODUCIBLE with server installation of official en-US 
   SeaMonkey 2.49a1  (NT 6.1;  WOW64; rv:52.0) Gecko/20100101 Firefox/52.0 
   Build 20161111004200  (Default Classic Theme) on German WIN7 64bit
f) was still ok with server installation of official en-US SeaMonkey 2.49a1
   (NT 6.1; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0 
   Build 20161107002359  (Default Classic Theme) on German WIN7 64bit
Jork,

does this also happen in TB 52 or 53?
Flags: needinfo?(jorgk)
I subscribed to http://www.tagesschau.de/xml/rss2 with my local TB 53 build and the messages in the feed look good in the message. However, if opened in a new tab I get what you see in Rainer's screenshot, but with the message rendered properly below.

Maybe a problem from bug 1316256.

Alta88, can you please take a look.
Flags: needinfo?(jorgk) → needinfo?(alta88)
Correction:

(In reply to Jorg K (GMT+1) from comment #8)
> I subscribed to http://www.tagesschau.de/xml/rss2 with my local TB 53 build
> and the messages in the feed look good in the message *pane*. However, if opened in
> a new tab I get what you see in Rainer's screenshot, but with the message
> rendered properly below.

Comment 11

2 years ago
of course it's bug 1316256, it regressed the fix in bug 662907.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(alta88)
Resolution: --- → DUPLICATE
Duplicate of bug: 1316256
Alice, can you please confirm this.

STR:
Thunderbird.
Create a feed account and subscribe to http://www.tagesschau.de/xml/rss2
Double click on a message to open it in a tab.

Maybe it's bug 1316256 which is caused by bug 1308889 which landed on Gecko52 on 2016-11-08.
To the regression range is one day, just try before and after that day. I trust Alta88's assessment, but I want to make "double sure" in order not to attribute blame to the wrong bug.
Flags: needinfo?(alice0775)

Comment 13

2 years ago
(In reply to Jorg K (GMT+1) from comment #12)

> Double click on a message to open it in a tab.


I cannot reproduce the problem on Win10 64bit Tb 32bt 2016-11-18 build.


Is this intermittent problem?
Flags: needinfo?(alice0775)
No. I can see it in Daily 53.0a1 (2016-11-15) (64-bit) and my local trunk build.

I'll try myself. Thanks anyway.
Good in 52.0a1 (2016-11-08) (32-bit).
Bad  in 52.0a1 (2016-11-09) (32-bit).
So I guess the regression from bug 1308889 now tracked in bug 1316256 is confirmed.
Yes, and bug Bug 1308889 is right in the middle of the M-C regression range. Thanks again.
You need to log in before you can comment on or make changes to this bug.