Expanding/collapsing a job group just returns to pre-click state

RESOLVED FIXED

Status

Tree Management
Treeherder
P2
normal
RESOLVED FIXED
a year ago
11 months ago

People

(Reporter: jfrench, Assigned: wlach)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
If you click on a job group to expand it or collapse it, the click event seems to be getting invoked twice, and the job group fleetingly expands(or collapses) and returns to its pre-clicked state.

To reproduce:
o on production, click on a job group label (eg. the "e10s" in "e10s(+4)"

Expected
o the group should expand and reveal 4 jobs

Observed:
o the group fleetingly expands, then re-collapses

The same is true of the group was expanded by directly clicking on the +4 and attempting to collapse it by clicking on "e10s". Instead of collapsing, it fleetingly collapses, and re-expands.
(Reporter)

Updated

a year ago
Priority: -- → P2
Likely more fallout from bug 1315375, will take a look on Monday.
Flags: needinfo?(wlachance)
Created attachment 8812799 [details] [review]
[treeherder] wlach:1318893 > mozilla:master
Comment on attachment 8812799 [details] [review]
[treeherder] wlach:1318893 > mozilla:master

I think the right solution here is just to make the job group symbol here a button, so that our custom behavior for jobs and job groups kicks in. I believe this also makes the group symbol more easily findable for those navigating treeherder with a screen reader, which is a good thing.
Flags: needinfo?(wlachance)
Attachment #8812799 - Flags: review?(tojonmz)
(Reporter)

Comment 4

a year ago
Comment on attachment 8812799 [details] [review]
[treeherder] wlach:1318893 > mozilla:master

Lgtm :) I tried the branch locally and did some brief integration testing and it seems to be fine.
Attachment #8812799 - Flags: review?(tojonmz) → review+
(Reporter)

Updated

a year ago
Assignee: nobody → wlachance
Status: NEW → ASSIGNED

Comment 5

a year ago
Commit pushed to master at https://github.com/mozilla/treeherder

https://github.com/mozilla/treeherder/commit/64dcd973f8c21b730a4624a4d1fa19b8c4bc7c40
Bug 1318893 - Fix click behaviour for job groups (#1989)

Do this by making the job groups a clickable button, which is incidentally
also better behaviour for screen readers (since it gives a hint that the
element is clickable)

Updated

11 months ago
Status: ASSIGNED → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.