[Windows 7 and below] Fullscreen window controls not shown with dark themes, close button has broken "red square" hover state

VERIFIED FIXED in Firefox 51

Status

()

Firefox
Theme
P1
normal
VERIFIED FIXED
a year ago
a year ago

People

(Reporter: Yuliya, Assigned: Gijs)

Tracking

({regression})

50 Branch
Firefox 53
x86_64
Windows 7
regression
Points:
---
Bug Flags:
qe-verify +

Firefox Tracking Flags

(firefox51 verified, firefox52 verified, firefox53 verified)

Details

Attachments

(4 attachments, 3 obsolete attachments)

(Reporter)

Description

a year ago
Created attachment 8812510 [details]
fx-fullscreen.png

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID: 20161104212021

Steps to reproduce:

1. Open Firefox
2. Enable Developer theme
(On Stable/Beta https://addons.mozilla.org/en-US/firefox/addon/devedition-theme-enabler/ is required; on Developer/Nightly it's already there under Add-ons > Appearance)
3. Press F11


Actual results:

Fullscreen window controls are not shown


Expected results:

Minimise/Resore/Close buttons should be present in the upper-right corner. 

The tooltip appears on hover, and the buttons (areas) work, but the visual indicator is missing, aside from a "minus" symbol where the Minimise button should be.
This is a problem with Firefox 50+, screenshot for comparison between v49 and v50 attatched (as seen on Windows 7).
(Reporter)

Updated

a year ago
Component: Untriaged → Theme
OS: Unspecified → Windows 7
Hardware: Unspecified → x86_64
(Assignee)

Comment 1

a year ago
Works fine with current devedition on Windows 10.

Can you reproduce with an up-to-date version of devedition and a clean profile (the one in the screenshot has add-ons)? ( https://www.mozilla.org/en-US/firefox/channel/desktop/#developer )

I wonder if this is somehow caused by bug 965322.
Has Regression Range: --- → no
Has STR: --- → yes
Flags: needinfo?(yuliyamaksimovna93)
Keywords: regression, regressionwindow-wanted
Summary: Fullscreen window controls not shown with Developer theme in Firefox 50+ → [Windows 7] Fullscreen window controls not shown with Developer theme in Firefox 50+
(Assignee)

Updated

a year ago
Assignee: nobody → gijskruitbosch+bugs
Blocks: 965322
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Flags: needinfo?(yuliyamaksimovna93)
Keywords: regressionwindow-wanted
(Assignee)

Updated

a year ago
Summary: [Windows 7] Fullscreen window controls not shown with Developer theme in Firefox 50+ → [Windows 7 and below][devedition theme] Fullscreen window controls not shown with dark developer theme in Firefox 50+
(Assignee)

Comment 2

a year ago
Created attachment 8812809 [details] [diff] [review]
use !important to force vista/7 controls in fullscreen even on dark themes,

MozReview-Commit-ID: eIleloCNMZ
(Assignee)

Updated

a year ago
Attachment #8812809 - Flags: review?(dao+bmo)
(Assignee)

Comment 3

a year ago
Created attachment 8812810 [details] [diff] [review]
use vista/7 style controls in fullscreen even on dark lwtheme/devedition

Not sure which of these 2 patches you prefer. Both work.
Attachment #8812810 - Flags: review?(dao+bmo)
(Assignee)

Updated

a year ago
Summary: [Windows 7 and below][devedition theme] Fullscreen window controls not shown with dark developer theme in Firefox 50+ → [Windows 7 and below] Fullscreen window controls not shown with dark developer theme (and likely other dark lwthemes, possibly dark classic themes)
(Reporter)

Comment 4

a year ago
(In reply to :Gijs Kruitbosch from comment #1)
> Works fine with current devedition on Windows 10.
> 
> Can you reproduce with an up-to-date version of devedition and a clean
> profile (the one in the screenshot has add-ons)? (
> https://www.mozilla.org/en-US/firefox/channel/desktop/#developer )
> 
> I wonder if this is somehow caused by bug 965322.

Yes, the issue is present on the latest Nightly (53.0a1 (2016-11-21) (64-bit)) too.
(Reporter)

Comment 5

a year ago
Created attachment 8812843 [details]
Nightly 53.0a1 (2016-11-21) (64-bit)

I noticed now that light theme works fine, it's only the dark one. No add-ons on this one (besides the system add-ons it comes with) and a clean profile.
(Reporter)

Comment 6

a year ago
Created attachment 8812851 [details]
53.0a1 (2016-11-21) (64-bit)_light_on_hover.png

Although close button becomes a red square on hover on light one.
(Assignee)

Comment 7

a year ago
(In reply to Yuliya from comment #6)
> Created attachment 8812851 [details]
> 53.0a1 (2016-11-21) (64-bit)_light_on_hover.png
> 
> Although close button becomes a red square on hover on light one.

This also happens on the default theme. That makes this a more significant problem.
Priority: -- → P1
Summary: [Windows 7 and below] Fullscreen window controls not shown with dark developer theme (and likely other dark lwthemes, possibly dark classic themes) → [Windows 7 and below] Fullscreen window controls not shown with dark themes, close button has broken "red square" hover state
(Assignee)

Comment 8

a year ago
Created attachment 8813161 [details] [diff] [review]
force using vista/7 style controls in fullscreen on those OSes
Attachment #8812810 - Attachment is obsolete: true
Attachment #8812810 - Flags: review?(dao+bmo)
(Assignee)

Updated

a year ago
Attachment #8813161 - Flags: review?(dao+bmo)
Attachment #8812809 - Flags: review?(dao+bmo) → review+
Attachment #8813161 - Flags: review?(dao+bmo)
(Assignee)

Comment 9

a year ago
Created attachment 8813633 [details] [diff] [review]
use !important to force vista/7 controls in fullscreen even on dark themes,

MozReview-Commit-ID: eIleloCNMZ
Attachment #8813633 - Flags: review?(dao+bmo)
(Assignee)

Updated

a year ago
Attachment #8812809 - Attachment is obsolete: true
(Assignee)

Updated

a year ago
Attachment #8813161 - Attachment is obsolete: true
Attachment #8813633 - Flags: review?(dao+bmo) → review+

Comment 10

a year ago
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/7f9e1e63b710
use !important to force vista/7 controls in fullscreen even on dark themes, r=dao

Comment 11

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/7f9e1e63b710
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
status-firefox53: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 53
(Assignee)

Comment 12

a year ago
Comment on attachment 8813633 [details] [diff] [review]
use !important to force vista/7 controls in fullscreen even on dark themes,

Approval Request Comment
[Feature/regressing bug #]: bug 965322
[User impact if declined]: broken window button styling in fullscreen on Windows 7 and below
[Describe test coverage new/current, TreeHerder]: nope, styling only
[Risks and why]: low-ish, styling only.
[String/UUID change made/needed]: nope
Attachment #8813633 - Flags: approval-mozilla-beta?
Attachment #8813633 - Flags: approval-mozilla-aurora?
(Assignee)

Updated

a year ago
Flags: qe-verify?
Hi Brindusa, 
Can you have someone verify if this is fixed on latest nightly? Thanks.
Flags: needinfo?(brindusa.tot)
Flags: qe-verify?
Flags: qe-verify+
Flags: needinfo?(brindusa.tot)
QA Contact: simona.marcu
Mozilla/5.0 (Windows NT 6.1; rv:53.0) Gecko/20100101 Firefox/53.0
Build ID: 20161125030214

Verified as fixed using the latest Nightly 53.0a1 on Windows 7 - windows controls in full screen are properly displayed (with or without the dark theme).

Please note that the fix could not be verified on older OS'es than Windows 7 (Xp and Vista) because the latest Nightly can't be installed - "Sorry Nightly can't be installed. This version of Nightly requires Microsoft Windows 7 or newer".
Status: RESOLVED → VERIFIED
status-firefox53: fixed → verified
status-firefox51: --- → affected
status-firefox52: --- → affected
Comment on attachment 8813633 [details] [diff] [review]
use !important to force vista/7 controls in fullscreen even on dark themes,

Fix a theme issue in windows 7. Beta51+ and Aurora52+. Should be in 51 beta 4.
Attachment #8813633 - Flags: approval-mozilla-beta?
Attachment #8813633 - Flags: approval-mozilla-beta+
Attachment #8813633 - Flags: approval-mozilla-aurora?
Attachment #8813633 - Flags: approval-mozilla-aurora+

Comment 16

a year ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-aurora/rev/cf76a8e08edf
status-firefox52: affected → fixed

Comment 17

a year ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-beta/rev/4164d5620eac
status-firefox51: affected → fixed
Verified as fixed using the latest Firefox 51.0b4 (Build ID: 20161128075558)and Firefox Developer Edition 53.0a2 (Build ID: 20161129031443) on Windows XP, Windows Vista and Windows 7.
status-firefox51: fixed → verified
status-firefox52: fixed → verified
You need to log in before you can comment on or make changes to this bug.