Widevine doesn't work on amazon anymore.

RESOLVED WORKSFORME

Status

()

Core
Audio/Video: Playback
P1
normal
RESOLVED WORKSFORME
a year ago
a year ago

People

(Reporter: cougar1984, Unassigned)

Tracking

50 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(platform-rel -)

Details

(Whiteboard: [platform-rel-Amazon][platform-rel-AmazonVideo])

Attachments

(3 attachments)

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:49.0) Gecko/20100101 Firefox/49.0
Build ID: 20161025170457

Steps to reproduce:

I had install the update of firefox 50 on my notebook with Kubuntu 14.04. 


Actual results:

I can't start a video on amazon video anymore. I alway get an error message, that tells me, that there is an error with digital rights management and I should check my widevine plugin. It's still activated and up to date. Also the drm copyright protection is still active. 
On my desktop computer, also with Kubuntu 14.04 and Firefox 49 everything works good.
(Reporter)

Updated

a year ago
OS: Unspecified → Linux
Hardware: Unspecified → x86_64

Updated

a year ago
Component: Untriaged → Audio/Video: Playback
Product: Firefox → Core
platform-rel: --- → ?
Whiteboard: [platform-rel-Amazon][platform-rel-AmazonVideo]
Dale/Chris, do you think this could be due to CDM downloading?
platform-rel: ? → -
Flags: needinfo?(dale)
Flags: needinfo?(cpearce)
Created attachment 8820019 [details]
prompt to enable DRM

I just repro'd in my Ubuntu VM w/ 50. It prompts me to enable DRM, then I go to look at AddOns and it tells me Widevine stuff will be installed shortly. After it's installed, and I go back to the page, I see the same error (w/o prompt to enable DRM).
Created attachment 8820027 [details]
post install error

Note, doing all the suggestions in the error copy don't make a difference.
It's working fine for me in Ubuntu 12.04 with gnome/unity and Firefox 50.

What if you reload with CTRL+SHIFT+F5 to do a re-request of everything? There may be some state saved in your browser history that causes Amazon to assume Widevine won't work.
Flags: needinfo?(cpearce)
Sounds like an issue with the downloader.

Cougar1984/Mike Can you please follow the instructions here and paste the browser console log into this bug?

Dale - can you take a look at the results of the console log? Chris and I are AFK for a couple of weeks.
Will take a look at any log, I tried reproducing and couldnt see any problems, will leave needinfo to remind me
Priority: -- → P1
Clearing needinfo, wasnt able to reproduce nor see anything that indicates that its related to offline cdm downloading
Flags: needinfo?(dale)

Comment 8

a year ago
I have the same issue with Firefox 52.0.1 on openSUSE Leap 42.2. Worked fine (i think with Firefox version 50~51) before i upgraded the OS from the old openSUSE 13.1 for a few weeks. I think it's an issue in Leap especially with Firefox. Widevine works fine with other browsers (tested with Google Chrome 57) on Leap 42.2. But i want to prefer Firefox.

In the browser log there is a message with "Key system configuration is not supported", maybe this is the problem?

I have attached the browser console log.

Comment 9

a year ago
Created attachment 8851258 [details]
browser console log

Comment 10

a year ago
I have overlooked an error message in the browser console log:
"cannot play media. No decoders for requested formats: audio/mp4, video/mp4  browser.xul"

I have seen, playback of mp4 video also doesn't work with the dragon player. 
With VLC there is no problem.

I try to figure out the problem.

Comment 11

a year ago
Fixed it. The default (from the official openSUSE repo) FFmpeg library libavcodev57 was installed. It didn't work with this version of the library. I have now installed the full version of the Packman repo. Playback works now.
I cannot reproduce it on "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:53.0) Gecko/20100101 Firefox/53.0".

I did see the same prompt in attachment 8820019 [details], then I went to "about:preferences > Content > DRM content" and check "Play DRM content" (which was not checked) and everything works fine thereafter.

:miketaylr, does this help?
Flags: needinfo?(miket)
It does yeah. I'm not sure if that was checked originally when I commented (I've since reinstalled Ubuntu), but it's working now. Let's close as WFM, but please re-open or comment if I'm missing something.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(miket)
Resolution: --- → WORKSFORME
(In reply to Mike Taylor [:miketaylr] from comment #13)
> It does yeah. I'm not sure if that was checked originally when I commented
> (I've since reinstalled Ubuntu), but it's working now. Let's close as WFM,
> but please re-open or comment if I'm missing something.

Thanks for verifying!
You need to log in before you can comment on or make changes to this bug.