Closed Bug 1318987 Opened 4 years ago Closed 2 years ago

Implement PaymentRequest interface

Categories

(Core :: DOM: Web Payments, defect, P3)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1318984

People

(Reporter: marcosc, Unassigned)

References

(Blocks 1 open bug, )

Details

(Keywords: meta)

A web page creates a PaymentRequest to make a payment request. This is typically associated with the user initiating a payment process (e.g., selecting a "Power Up" in an interactive game, pulling up to an automated kiosk in a parking structure, or activating a "Buy", "Purchase", or "Checkout" button). The PaymentRequest allows the web page to exchange information with the user agent while the user is providing input before approving or denying a payment request.
Blocks: 1318988
No longer blocks: 1318988
Mapping the Trello_P1 priority into bugzilla P3.
Priority: -- → P3
No longer depends on: 1345369
No longer depends on: 1345366
No longer depends on: 1345365
No longer depends on: 1345367
DOM: Device Interfaces is a better fit.
Component: DOM → DOM: Device Interfaces
Component: DOM: Device Interfaces → DOM: Web Payments
Depends on: 1376623
Depends on: 1369334
Depends on: 1367694, 1367668
Depends on: 1336760
Depends on: 1368949
Depends on: 1379892
Depends on: 1379925
Depends on: 1380211
Depends on: 1435157
Keywords: meta
I'm closing this as a duplicate of bug 1318984. Because of .retry(), PaymentRequest and PaymentResponse are intertwined, so just focusing on "Payment Request API" at large makes more sense.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: paymentrequest
You need to log in before you can comment on or make changes to this bug.