Lost all Preferences for Browser and Mailer

VERIFIED DUPLICATE of bug 155080

Status

--
major
VERIFIED DUPLICATE of bug 155080
17 years ago
14 years ago

People

(Reporter: dg2ms, Assigned: bugs)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.9) Gecko/20020311
BuildID:    2002031104

Aproximatly 10 or 15 times starting w2k-prof with using Mozillas quicklaunch
option, both, the Browser and the Mailer, lose all their settings, MailAccount-
and Browsersettings, everything ist set up to it's default setting, only
Bookmarks are stored.
However, all the Mails are in their normal directorys so the settings seems not
to be lost, only overwritten?

W2k is started with default user so you dont have to log in, Mozilla has only
it's default settings, no additonal user.

Reproducible: Sometimes
Steps to Reproduce:
1.Only start windows2k with Mozillas Quicklaunch option
2.Start Mozilla
3.Start Mailer

Actual Results:  
1. Normal startup
2. Starting Page is set to default (Mozilla.org)
2. Mailer window appears, asking to set up account

Using some goodies like firewall and antivirus programms, but it dont seemed
that this is the cause.

Anyone here the same problem?

Comment 1

17 years ago
se,
Do you see this?

Comment 2

17 years ago
The same happened to me on a build form teh trunk pulled about 3 hours ago:

This is a directory of my profile directory:
1) I never had Mail folders 
2) i had files like prefs.diff and prefs.js in the directory.
3) It looks like my cookies survived
4) Althoguh there is no prefs.js file (I havn't restarted my browser since the
problems), my prefs still seem okay (Verified by going into edit:preferences)
5) My bookmarks were Replaced by the origionals

Here is a listing of the profiule directory

drwxr-xr-x   2 marcus   other        512 Mar 20 15:53 ./
drwxr-xr-x   3 marcus   other        512 Mar 20 15:30 ../
-rw-r--r--   1 marcus   other      29780 Mar 20 15:46 XUL.mfasl
-rw-r--r--   1 marcus   other       5782 Mar 20 15:30 bookmarks.html
-rw-------   1 marcus   other      32768 Mar 20 15:34 cert7.db
-rw-r--r--   1 marcus   other       1316 Mar 20 16:04 cookies.txt
-rw-r--r--   1 marcus   other        287 Mar 20 16:03 cookperm.txt
-rw-r--r--   1 marcus   other        509 Mar 20 15:30 history.dat
-rw-------   1 marcus   other      32768 Mar 20 15:34 key3.db
-rw-r--r--   1 marcus   other      30334 Mar 20 16:03 localstore.rdf
-rw-r--r--   1 marcus   other        287 Mar 20 15:42 mimeTypes.rdf
-rw-r--r--   1 marcus   other       2335 Mar 20 15:31 search.rdf
-rw-------   1 marcus   other      32768 Mar 20 15:34 secmod.db

my .mozconfig file is:
ac_add_options --disable-debug
ac_add_options --enable-crypto
ac_add_options --disable-tests
ac_add_options --enable-optimize
ac_add_options --disable-mailnews
ac_add_options --enable-plaintext-editor-only
ac_add_options --with-extensions=default

ac_add_options --disable-ldap
ac_add_options --disable-xprint
ac_add_options --enable-js-ultrasparc

I had jsut done a gmake -wf client.mk clobber && gmake -wf client.mk
on solaris 8.

Comment 3

17 years ago
After restarting, my profile directory looks like this:
drwxr-xr-x   2 marcus   other        512 Mar 20 17:42 ./
drwxr-xr-x   3 marcus   other        512 Mar 20 17:42 ../
-rw-r--r--   1 marcus   other       5782 Mar 20 17:42 bookmarks.html
-rw-r--r--   1 marcus   other        509 Mar 20 17:42 history.dat
(my bookmarks.dat is deleted and replaced with the default one)
After comming accross a cookie, my cookies.txt appears, witht he right details
My preferences seem to be allright though, even though there isn;'t a prefs.js
file. I'm aobut to test a new build.

Comment 4

17 years ago
After quitting that buiuld, my prefs directory looks like this:

drwxr-xr-x   3 marcus   other        512 Mar 20 17:50 ./
drwxr-xr-x   3 marcus   other        512 Mar 20 17:42 ../
-rw-r--r--   1 marcus   other      57442 Mar 20 17:44 XUL.mfasl
-rw-r--r--   1 marcus   other       5475 Mar 20 17:50 bookmarks.html
-rw-------   1 marcus   other      32768 Mar 20 17:50 cert7.db
drwxr-xr-x   2 marcus   other        512 Mar 20 17:44 chrome/
-rw-r--r--   1 marcus   other       1316 Mar 20 17:45 cookies.txt
-rw-r--r--   1 marcus   other        156 Mar 20 17:45 cookperm.txt
-rw-r--r--   1 marcus   other       2454 Mar 20 17:50 history.dat
-rw-------   1 marcus   other      32768 Mar 20 17:50 key3.db
-rw-r--r--   1 marcus   other      30912 Mar 20 17:44 localstore.rdf
-rw-r--r--   1 marcus   other        287 Mar 20 17:45 mimeTypes.rdf
-rw-r--r--   1 marcus   other       6110 Mar 20 17:50 prefs.js
-rw-------   1 marcus   other      32768 Mar 20 17:44 secmod.db

The new build doesn't seem to be wiping the directory out anymore.

Comment 5

17 years ago
This bug shows up in Netscape 6.2.2 commercial release, I have saved
the preference files (before they were wiped out). If it can provide 
any clues to this critical problem, I can provide it to the engineer
who maybe working on it.

Comment 6

17 years ago
-> Ben
Assignee: sgehani → ben

Comment 7

17 years ago
(I was going to open a new bug but saw this one; so I'm adding mine to
the information.  My workaround might be useful to others with the
problem.  My OS is Windows XP.)

Subject:  prefs.js is randomly reset to initial default

Every few days when Mozilla is started, it changes my prefs.js file to
the initial installation default for no apparent reason.  This happens
on RC1, happened on 0.9.9 previously and NS6.2.1(?) before that.  When it
gets in this mode, even if I exit Mozilla completely and restore
prefs.js from backup, it refuses to recognize the old one (that worked
before) and still wipes it out back to the installation default.  IIRC
even after rebooting, restoring prefs.js, then starting Mozilla it still
wipes it out when it has gotten into this mode.  If I then go through
the normal profile configuration process, then recover my Inbox etc. by
hand into the new folder it creates, it works OK for a while.

I discovered that if I make prefs.js read-only there is never a problem.
If I want to change something I can allow writes after Mozilla has
started, then Edit->Preferences..., then make it read-only again after
exiting Mozilla.  This is my current workaround.

This is an intermittent problem I cannot reproduce consistently.  Could
a developer tell me what condition could cause Mozilla to ignore the
current prefs.js and create a new installation default on top of it?  I
am willing to try to pin this down if I know what to look for.  Could it
be some registry thing?

(As an aside I noticed that somethings changes prefs.pc8 whenever I
update prefs.js from backup, even if I'm not in Mozilla.  What process
is doing this?  I am curious :)

I am not the only one seeing this problem, although it seems to be very
rare.  This is from a newsgroup posting:

>>I'm using XP and N6.2.1.  In the mail part I have 3 mail accounts, a
>>newsgroup account with a subscription list, and an IM name def.  I also
>>have N6 set to start with the mail app only, not the browser etc.
>>
>>About 3-5 times a week, I start it seems to have 'lost' some key def
>>file and it comes up with the browser (not the mail app) on the default
>>home page, but with all my addrs and bookmarks OK.  When I click to
>>invoke the mail app, it has 'lost' all my stuff and I have to redefine
>>the accounts.  I have not lost any data because I know how to save the
>>old mail folders before rebuilding the new ones in the redefine process,
>>then copy all the old mail files into the newly built ones.  It's just a
>>pain to have to do this for 10 mins that often.
>>
>>Has anyone else seen this problem?  I have all the latest XP fixes.

Comment 8

17 years ago
Confirming based on comment 7.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 9

17 years ago
I see this bug too with the same random causes.  I don't think there's any
connection, but the first time I had viewed 'about:config' during the session
(tried it again -- no effect), the second time the system was low on memory and
thrashing badly (too long to load prefs??).  Win98SE, several trunk builds.

Comment 10

17 years ago
It happened to me on 2 different computers each with 2k-pro and  mozilla 1.0
(without quick launch)

Comment 11

17 years ago
kees, do you have multiple profiles?
i haven't encountered this problem (yet) on win2k --but then again i've got
multiple profiles and do not use quicklaunch.

if this is indeed limited to quicklaunch, this might be a dup of bug 155080 (or,
vice versa).

Comment 13

17 years ago
I have similar problem (id=143516), and I've tracked the culprit as Trend
Micro's PC Cillin 2000 POP3 Scan (Trap) program (v. 7.61), which is supposed to
act as a proxy and scan incoming POP mail. Details can be found here
http://solutionbank.antivirus.com/solutions/solutionDetail.asp?solutionID=10700

Mozilla Mail seems to be incompatible with Pop3 scan v.7.61

Comment 14

17 years ago
kees answered comment 11 by email "no i was not using multiple profiles, but i
am using PC Cillin 2000"

Comment 15

17 years ago
Bingo.
My prefs.js appears to be reset to a minimal file at Mozilla startup.
On a WinME box.
Mozilla was upgraded on 8/9: "version 1.1b"
Perhaps 3 or 4 restarts (days) afterward, email account settings were lost.
I will:
 - Restore a March '02 version of prefs.js
 - Set prefs.js to Read-Only

Chris Barr

Comment 16

17 years ago
I can reproduce something like this bug once/day.  At some point either just
starting or several page views into the session my system W2k sp2, moz 1.1b, my
system will freeze completely (system clock stops running), at this point I have
to power down, at some point during the process prefs/bookmarks are overwritten
the next time I start Mozilla.  I have multiple users on this machine (2).  If
other files are open there is a chance they will corrupt as well.

This only happens once / day for some reason or other so far!!  I don't have
pCillin on machine.  Haven't tried the read only permissions on prefs.js

Have kept a copy of prefs/bookmarks backed up for replacement, which seems to be
the quickest fix.

This bug may be linked to a browers hangs if "null" page is returned I saw
listed elsewhere, similar "symptoms" there...

Comment 17

17 years ago
today, I've done this twice in 30minutes ... re-set all the preferences,
recreate mail accounts, and then all this again. I'm pretty sure I can discover
the trigger event ... working on it ...

Here are my latest experiences, hope it can help.
1) this often happens when I open a local file in Browser. When I close it, a
dialog appears, saying something like "Quick Launch is enabled, it will speed up
starting...etc."
2) prefs.bak contains default preferences
3) form, cookie, download and image manager stay, password manager is cleared,
although the passwords file is still in its place

I'm not using any POP scanning software. I have Win98SE with LiteStep
dupping, but reopen if this is clearly not a dup.

*** This bug has been marked as a duplicate of 155080 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
mass-verification of Duplicates.

mail search string for bugspam: SolarFlaresAreTheCause
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.