Crash reporter crash loop: NullPointerException: 'void org.mozilla.gecko.EventDispatcher.registerGeckoThreadListener(org.mozilla.gecko.util.NativeEventListener, java.lang.String[])' on a null object reference

RESOLVED FIXED in Firefox 53

Status

()

Firefox for Android
General
P1
normal
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: sebastian, Assigned: jchen)

Tracking

unspecified
Firefox 53
All
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(fennec+, firefox53 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
In Nightly I see a crash loop: Whenever the crash report shows up and I press "Close" then immediately a new instance of the crash reporter is shown.

No crash report is ever send but with logcat I see:

>      GeckoCrashHandler  E  >>> REPORTING UNCAUGHT EXCEPTION FROM THREAD 1 ("main")
>                         E  java.lang.NullPointerException: Attempt to invoke virtual method 'void org.mozilla.gecko.EventDispatcher.registerGeckoThreadListener(org.m
>                            ozilla.gecko.util.NativeEventListener, java.lang.String[])' on a null object reference
>                         E      at org.mozilla.gecko.MediaPlayerManager.onCreate(MediaPlayerManager.java:82)
>                         E      at android.support.v4.app.Fragment.performCreate(Unknown Source)
>                         E      at android.support.v4.app.FragmentManagerImpl.moveToState(Unknown Source)
>                         E      at android.support.v4.app.FragmentManagerImpl.moveToState(Unknown Source)
>                         E      at android.support.v4.app.FragmentManagerImpl.moveToState(Unknown Source)
>                         E      at android.support.v4.app.FragmentManagerImpl.dispatchCreate(Unknown Source)
>                         E      at android.support.v4.app.FragmentController.dispatchCreate(Unknown Source)
>                         E      at android.support.v4.app.FragmentActivity.onCreate(Unknown Source)
>                         E      at android.support.v7.app.AppCompatActivity.onCreate(Unknown Source)
>                         E      at org.mozilla.gecko.GeckoActivity.onCreate(GeckoActivity.java:45)
>                         E      at org.mozilla.gecko.GeckoApp.onCreate(GeckoApp.java:1222)
>                         E      at org.mozilla.gecko.BrowserApp.onCreate(BrowserApp.java:612)
>                         E      at android.app.Activity.performCreate(Activity.java:6679)
>                         E      at android.app.Instrumentation.callActivityOnCreate(Instrumentation.java:1118)
> [..]
(Reporter)

Updated

2 years ago
tracking-fennec: --- → ?
status-firefox53: --- → affected
Priority: -- → P1
I think I'm seeing this too. If I remove Nightly from the list of running apps, and then restart, I'm able to get Nightly to run.
(Reporter)

Comment 2

2 years ago
@jim: Could this be caused by the recent event dispatcher changes?
Flags: needinfo?(nchen)
(Assignee)

Comment 3

2 years ago
Yeah, looks like regression from bug 1307820.
Assignee: nobody → nchen
Blocks: 1307820
Flags: needinfo?(nchen)
(Assignee)

Comment 4

2 years ago
Created attachment 8812933 [details] [diff] [review]
Register MediaPlayerManager events later (v1)

Wait to register MediaPlayerManager events until we have a GeckoApp
EventDispatcher. Use onStart/onStop because we only have an EventDispatcher
after we create the GeckoView in onCreate. onDestroy was annotated as
JNITarget, but I couldn't find where it's used, so I removed it.
Attachment #8812933 - Flags: review?(s.kaspari)
(Reporter)

Updated

2 years ago
Attachment #8812933 - Flags: review?(s.kaspari) → review+
(Reporter)

Updated

2 years ago
See Also: → bug 1318074
Duplicate of this bug: 1318074

Comment 6

2 years ago
Pushed by nchen@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/5bc8f7e5e1d2
Register MediaPlayerManager events later; r=sebastian

Comment 8

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/5bc8f7e5e1d2
https://hg.mozilla.org/mozilla-central/rev/3a2815ffb71e
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox53: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 53
(Reporter)

Updated

2 years ago
tracking-fennec: ? → +
(Reporter)

Updated

2 years ago
Duplicate of this bug: 1319969
(Assignee)

Updated

2 years ago
Depends on: 1320602
You need to log in before you can comment on or make changes to this bug.