Closed Bug 1319233 Opened 3 years ago Closed 2 years ago

Using a more recent compiler for official builds

Categories

(Firefox Build System :: General, enhancement)

50 Branch
x86_64
Linux
enhancement
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1389435

People

(Reporter: L.Bonnaud, Unassigned)

Details

Hi,

according to about:buildconfig all official Firefox Linux builds (32 and 64 bits; release, beta, aurora, nightly) use gcc 4.8.5.

This is a fine compiler but it lacks interesting features such as some security hardening options and improved optimization options.

Some Linux distributions already use more recent gcc versions (gcc 6) to provide their own builds.

So would it be possible to upgrade gcc on the build systems ?
I noticed that since recently aurora builds use gcc 4.9.
This is a good step forward :>.
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → INVALID
We switched to using GCC 6 for official builds in bug 1389435.
Resolution: INVALID → DUPLICATE
Duplicate of bug: gcc6
Component: Build Config → General
Product: Firefox → Firefox Build System
You need to log in before you can comment on or make changes to this bug.