Can't log in to TekSavvy with Google account with tracking protection enabled

RESOLVED DUPLICATE of bug 1273531

Status

()

Firefox
Tracking Protection
RESOLVED DUPLICATE of bug 1273531
a year ago
4 months ago

People

(Reporter: jdm, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
Visiting https://myaccount.teksavvy.com/ in FF nightly and clicking the "Sign in with Google" link yields `ReferenceError: gapi is not defined`. In Chrome, it works fine.

The page contains

<script src="https://plus.google.com/js/client:platform.js" type="text/javascript" async defer></script>
<script src="/Binding/ViewModels/AccountLoginViewModel.js?version=1.11" type="text/javascript"></script>

where the first script defines window.gapi and the second uses it. The page has finished loading by the time I click the link, but client:platform.js doesn't show up in the list of scripts in the debugger, which suggests to me that it's never executed.

The page works fine in Chrome.
(Reporter)

Comment 1

a year ago
This was caused by having tracking protection enabled, since this blocks the script from plug.google.com.
Component: DOM → Tracking Protection
Product: Core → Firefox
Summary: Can't log in to TekSavvy with Google account → Can't log in to TekSavvy with Google account with tracking protection enabled
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1273531
You need to log in before you can comment on or make changes to this bug.