Rendering artifacts with layers.enable-tiles regression in Firefox 50 on Linux

NEW
Unassigned

Status

()

Core
Graphics: Layers
P3
normal
a year ago
a year ago

People

(Reporter: Ernst Sjostrand, Unassigned)

Tracking

50 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [gfx-noted])

Attachments

(2 attachments)

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID: 20161114144856

Steps to reproduce:

Set layers.enable-tiles to true.
Open slack for example.


Actual results:

Rendering artifacts with square shapes in wrong (solid) color.
(Reporter)

Comment 1

a year ago
This happens with and without OpenGL composited layers.
With both Cairo and Skia content rendering.
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
Summary: Rendering artifacts with layers.enable-tiles regression in Firefox 50 → Rendering artifacts with layers.enable-tiles regression in Firefox 50 on Linux
(Reporter)

Comment 2

a year ago
Created attachment 8813078 [details]
support.txt
(Reporter)

Comment 3

a year ago
This was working with Firefox 49.

(The reason I enabled layers.enable-tiles was that I get rendering artifacts with GL composited rendering at 4K resolution without tiles.)
(Reporter)

Comment 4

a year ago
Created attachment 8813084 [details]
screenshot.png

https://slack.com/ seems to be a good demo for the issue also.
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:53.0) Gecko/20100101 Firefox/53.0

I have tested your issue on latest Firefox release v50.0, latest Nightly build (Buid ID; 20161124030208) and managed to reproduce it. I have followed the steps from comment 0 and used the website from comment 4.
Status: UNCONFIRMED → NEW
Component: Untriaged → Graphics: Layers
Ever confirmed: true
Product: Firefox → Core

Updated

a year ago
Has STR: --- → yes
Priority: -- → P3
Whiteboard: [gfx-noted]
You need to log in before you can comment on or make changes to this bug.