WebExtensions: chrome.tabs.setZoomSettings() should not require defaultZoomFactor to be set

RESOLVED DUPLICATE of bug 1286953

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 1286953
a year ago
a year ago

People

(Reporter: dw-dev, Unassigned)

Tracking

49 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0
Build ID: 20160922113459

Steps to reproduce:

I have recently developed a WebExtensions add-on, Zoom Page WE, based on my original XUL/XPCOM Zoom Page add-on.

Zoom Page WE has now been released on both Firefox and Chrome.

I have noticed that the WebExtensions implementation of chrome.tabs.setZoomSettings() is not fully compatible with the Chrome implementation.



Actual results:

With WebExtensions, chrome.tabs.setZoomSettings() requires that the tabs.ZoomSettings.defaultZoomFactor property is set to 1.0.

With Chrome, chrome.tabs.setZoomSettings() ignores the tabs.ZoomSettings.defaultZoomFactor property.

The Chrome behaviour is the correct behaviour, because both the Chrome and WebExtensions documentation for tabs.ZoomSettings state that:

"defaultZoomFactor - The default zoom level for the current tab. Note that this is only used in tabs.getZoomSettings."



Expected results:

chrome.tabs.setZoomSettings() should ignore the tabs.ZoomSettings.defaultZoomFactor property.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1286953
You need to log in before you can comment on or make changes to this bug.