--with-system-nss fails to build despite being advised via AC_MSG_ERROR for Tier3 platforms

RESOLVED FIXED in Firefox 53

Status

RESOLVED FIXED
2 years ago
8 months ago

People

(Reporter: jbeich, Assigned: ted)

Tracking

({regression})

Trunk
mozilla53
regression

Firefox Tracking Flags

(firefox50 unaffected, firefox51 unaffected, firefox52 unaffected, firefox53 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
$ echo ac_add_options --with-system-nspr >>.mozconfig
$ echo ac_add_options --with-system-nss >>.mozconfig
$ ./mach build
[...]
Creating config.status
Reticulating splines...
Traceback (most recent call last):
  File "configure.py", line 107, in <module>
    sys.exit(main(sys.argv))
  File "configure.py", line 31, in main
    return config_status(config)
  File "configure.py", line 102, in config_status
    return config_status(args=[], **encode(sanitized_config, encoding))
  File "python/mozbuild/mozbuild/config_status.py", line 147, in config_status
    definitions = list(definitions)
  File "python/mozbuild/mozbuild/frontend/emitter.py", line 234, in emit
    objs = list(self._emit_libs_derived(contexts))
  File "python/mozbuild/mozbuild/frontend/emitter.py", line 268, in _emit_libs_derived
    self._link_libraries(context, obj, variable)
  File "python/mozbuild/mozbuild/frontend/emitter.py", line 385, in _link_libraries
    context)
mozbuild.frontend.reader.SandboxValidationError:
==============================
ERROR PROCESSING MOZBUILD FILE
==============================

The error occurred while processing the following file or one of the files it includes:

    security/manager/ssl/moz.build

The error occurred when validating the result of the execution. The reported error is:

    USE_LIBS contains "crmf", which does not match any LIBRARY_NAME in the tree.


*** Fix above errors and then restart with\
               "/usr/local/bin/gmake -f client.mk build"
gmake: *** [client.mk:379: configure] Error 1
Oh, oops, apparently I removed config/external/nss/crmf and didn't replace it with anything:
https://hg.mozilla.org/mozilla-central/rev/ee70776759bf#l3.2
Assignee: nobody → ted
Comment hidden (mozreview-request)
Turns out we already put `-lcrmf` in `NSS_LIBS` in the `MOZ_SYSTEM_NSS` case, so the fix for this is really simple!
https://dxr.mozilla.org/mozilla-central/rev/0ddfec7126ec503b54df9c4b7c3b988906f6c882/old-configure.in#2115

Comment 4

2 years ago
mozreview-review
Comment on attachment 8813835 [details]
bug 1319405 - fix --with-system-nss build.

https://reviewboard.mozilla.org/r/95176/#review95398

Works for me!
Attachment #8813835 - Flags: review?(mshal) → review+

Comment 5

2 years ago
Pushed by tmielczarek@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/10a01f31d432
fix --with-system-nss build. r=mshal

Comment 6

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/10a01f31d432
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox53: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla53
status-firefox50: --- → unaffected
status-firefox51: --- → unaffected
status-firefox52: --- → unaffected

Updated

8 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.