c++ comments break mkdepend on win32

VERIFIED DUPLICATE of bug 132232

Status

P1
critical
VERIFIED DUPLICATE of bug 132232
17 years ago
14 years ago

People

(Reporter: netscape, Assigned: netscape)

Tracking

Trunk
mozilla1.0
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Since MSVC accepts c++ style comments by default, someone hacked mkdepend to
parse those comments out, which should speed up parsing by a bit.  However, due
to a bug, mkdepend tends to ignore the entire file that has c++ style comments
so that no deps are generated.
Created attachment 74929 [details] [diff] [review]
"erase" the newline at the end of the comment
Keywords: mozilla1.0
Priority: -- → P1
Target Milestone: --- → mozilla1.0
Comment on attachment 74929 [details] [diff] [review]
"erase" the newline at the end of the comment

r=bryner
Attachment #74929 - Flags: review+

Comment 3

17 years ago
Comment on attachment 74929 [details] [diff] [review]
"erase" the newline at the end of the comment

sr=alecf
Attachment #74929 - Flags: superreview+
I'm going to dupe this against the "land pristine mkdepend" bug as this problem
clears right up once when using the latest release of makedepend.

*** This bug has been marked as a duplicate of 132232 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 5

17 years ago
verified duplicate.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.