Menu-cancelling click should fall through (event should be accepted)

VERIFIED DUPLICATE of bug 21390

Status

SeaMonkey
UI Design
VERIFIED DUPLICATE of bug 21390
16 years ago
13 years ago

People

(Reporter: Tom Chiverton, Assigned: Peter Trudelle)

Tracking

Trunk
Future
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.9) Gecko/20020311
BuildID:    2002031104

When a drop down main menu item is active, the side  scroll bar does not work.

Reproducible: Always
Steps to Reproduce:
1. Click File menu item label, menu drops down
2. Try to drag side scroll bar

Actual Results:  Node in scroll bar does not move

Expected Results:  Scroll bar should work
(Assignee)

Updated

16 years ago
Target Milestone: --- → Future

Comment 1

16 years ago
Tom, can you explain which scrollbar you are talking about exactly ?

The menus are modal, when you try to click elsewhere the menu should
close. So I don't understand how any scrollbars are expected to work :)
(Reporter)

Comment 2

16 years ago
The menu does close, but the nodule in the scroll bar does not follow along with
the mouse while the button is held down.
The file menu does go away, but the page does not scroll.

Still in RC1 (2002041711).

Comment 3

16 years ago
OK, I see what you're saying :

1. click on File
2. release mouse button
3. go to scrollbar,and press and hold button 1

Expected results: menu closes and scrollbar reacts to movement

actual results: menu closes, scrollbar doesn't react

Probably reported somewhere I'm sure..
(Reporter)

Comment 4

16 years ago
Yes, here.

Comment 5

16 years ago
somewhere /else/ then ...
(Reporter)

Comment 6

16 years ago
Not anyone elsein bugzilla I can find.

Mark as dup if you find it :-)

Updated

16 years ago
Summary: side scroll bar does not work → Menu-cancelling click should fall through (event should be accepted)

Comment 7

16 years ago
OK found it. Apparently some versions of IE do do this, some don't. At
least Mozilla is consistent.

*** This bug has been marked as a duplicate of 21390 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 8

16 years ago
v
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.