Closed Bug 1319544 Opened 3 years ago Closed 2 years ago

Featured images on Advancing WebRTC are displayed badly

Categories

(Infrastructure & Operations :: Blogs, task)

task
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: pehrsons, Assigned: danielh)

Details

(Whiteboard: [kanban:https://webops.kanbanize.com/ctrl_board/2/5686])

Attachments

(3 files)

Advancing WebRTC, at blog.mozilla.org/webrtc, is a Wordpress site and posts have the ability to assign a "featured image" that will then appear in a meta og:image tag.

However we can't use the feature for this purpose since the site will also render the same image above the title in a 120x120 format. That doesn't look good.

I would have expected the image to appear in a meta tag and *not* in the rendered post.

See the screenshot in the URL field for an example of a featured image showing up on a post.

Without specifying a featured image, there will be a default meta tag with the first image in the post. In this case we wanted an image that looked like the embedded gif (video?) at the top of the post, but instead we have to go for an image that appears further down.
Pushed by lsalzman@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/d727d297aeee
allow WindowSurfaceX11Image to render to any visual format. r=rhunt
That must be the wrong bug?
Flags: needinfo?(lsalzman)
(In reply to Andreas Pehrson [:pehrsons] (Telenor) from comment #2)
> That must be the wrong bug?

Yes, typo run amok. Fixed by backout.
Flags: needinfo?(lsalzman)
Backout by lsalzman@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/87e3edcefc5b
Backed out changeset d727d297aeee for wrong bug number
Bulk move to Websites::blogs component, per bug 1353528
Component: blog.mozilla.org → blogs
Component: blogs → WebOps: Blogs
Product: Websites → Infrastructure & Operations
Whiteboard: [kanban:https://webops.kanbanize.com/ctrl_board/2/5560]
Closing this out 11 months later. Please file another bug if needed, thanks!
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
Whiteboard: [kanban:https://webops.kanbanize.com/ctrl_board/2/5560]
Really, nobody reaches out for those 11 months and still it's automatically a wontfix?

It's not hard to repro, you should be able to do it in a draft event.
Status: RESOLVED → REOPENED
Flags: needinfo?(jkrejci)
Resolution: WONTFIX → ---
Whiteboard: [kanban:https://webops.kanbanize.com/ctrl_board/2/5686]
Hey Andreas,

Sorry about the closing, WebOps was going through old bugs in the Blogs Component as we had an issue with our sync script. We were closing bugs older than 6 months. We tried to look into this issue however, we couldn't reproduce and cannot access the screenshot anymore. Can you go ahead and get us a new screenshot and we can file a bug with WP Engine. Sorry again!

- Joey K
Flags: needinfo?(jkrejci) → needinfo?(apehrson)
Attached image 1-Add_Media.png
Step 1: When editing a post, Add Media
Step 2: On the left select Featured image, pick an image and click "Set featured image"
Step 3: Results

Expected: Shows up as a `<meta property="og:image"...` in code

Actual: It does. That's what I want.


Expected: Not displayed in the post (for manual layout, i.e., I add a copy of it somewhere), or perhaps at the top of the post's content, automatically adjusted to match the width of the content.

Actual: Shows up as a thumbnail above the post's title without any options to remove or change this location. This renders the whole feature useless.
Flags: needinfo?(apehrson)
I hope this works.
Flags: needinfo?(jkrejci)
Cool deal, thanks Andreas! Im going to move this into our Next Sprint so we should probably have this moving and grooving in the next 2 weeks or so. Thanks for your patience! 

- Joey K
Flags: needinfo?(jkrejci)
Assignee: nobody → dhartnell
Hey Andreas,

I'm going to continue to look into this for you. I want to identify wheather or not the "featured image" option is expected to work in this way. In the meantime, I did notice that the Yoast SEO plugin enabled on your blog allows you to configure some "Social" options and it provides input for a "Facebook Title", "Facebook Description", and "Facebook Image". If you're not already aware, you can see this by editing a post, scrolling down to the Yoast SEO plugin section and clicking on the little universal icon for social between the gear and the stoplight.

Based on the documentation I found, I suspect that you can upload the image here and get it to function in the way you want. I would expect that to create the relevant "og:title", "og:description" and "og:image" tags which Facebook, Slack, etc. can read. Assuming they all respect that Open Graph tag - that was new to me.

I'll continue my investigation on Monday and keep you posted with my findings. If using the Toast SEO plugin works for you, let me know.

Thank you,
Daniel
Flags: needinfo?(apehrson)
Thank you Daniel!

This appears to work. The tags are present indeed.

This is enough for me. If the "featured image" feature wasn't there to steal attention from the beginning that would have been best, but nothing I can't live without.
Flags: needinfo?(apehrson)
Happy it worked for you, Andreas :)
Status: REOPENED → RESOLVED
Closed: 3 years ago2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.