Crash in cmsetac.dll@0x7178

RESOLVED WONTFIX

Status

External Software Affecting Firefox
Other
--
critical
RESOLVED WONTFIX
a year ago
a year ago

People

(Reporter: njn, Unassigned)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(1 attachment)

(Reporter)

Description

a year ago
This bug was filed from the Socorro interface and is 
report bp-5682a3d7-a476-4d93-b38c-7a0d22161122.
=============================================================

This is the #5 topcrash on Beta.

http://www.threatexpert.com/files/cmsetac.dll.html suggests that cmsetac.dll is malware, and some other sites agreed, though I'm not 100% certain.

The interesting thing is that the high number of crashes appear to be coming from a tiny number of installations:

> Product  Version  Count Percentage Installations
> Firefox  51.0b1   2961  85.4%      3
> Firefox  50.0b99   250  7.2%       3
> Firefox  50.0b11   137  4.0%       1
> Firefox  50.0b9     35  1.0%       1
> Firefox  50.0       34  1.0%       2
> Firefox  50.0b10    30  0.9%       3
> Firefox  50.0b8     19  0.5%       2
> Firefox  51.0a2      1  0.0%       1

dmajor, phillipp: any thoughts? I wanted to have a bug on file but perhaps we should just WONTFIX this one?
Flags: needinfo?(philipp.madersbacher)
Flags: needinfo?(dmajor)

Comment 1

a year ago
all of the reports are coming through the infobar submission mechanism. we already speculated yesterday on irc what may be the cause there, since the frequency of the reports seems quite like a bot: https://crash-stats.mozilla.com/signature/?product=Firefox&signature=cmsetac.dll%400x7178&page=1#reports

however based on the reports, there seem to be at least two different machines with different hardware involved, so we could just try adding that apparently malicious module onto the dll-blocklist...
Component: General → Other
Flags: needinfo?(philipp.madersbacher)
Product: Firefox → External Software Affecting Firefox

Comment 2

a year ago
Created attachment 8813726 [details] [diff] [review]
bug1319632_blocklist.patch

adding a patch for the dll blocklist, if we want to go that route...
The true volume here is tiny. IMO this isn't worth spending any engineering effort on.
Flags: needinfo?(dmajor)
(Reporter)

Updated

a year ago
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.