Closed Bug 1319790 Opened 3 years ago Closed 3 years ago

Crash in mozilla::MediaDecoder::NotifyBytesDownloaded

Categories

(Core :: Audio/Video: Playback, defect, P1, critical)

51 Branch
Unspecified
Windows 10
defect

Tracking

()

RESOLVED DUPLICATE of bug 1332544
Tracking Status
firefox52 --- affected

People

(Reporter: marcia, Unassigned)

References

Details

(Keywords: crash)

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is 
report bp-710daa98-0d80-427c-a71f-499ae2161122.
=============================================================

Seen while looking at Nightly Crash stats: http://bit.ly/2gB6m9E. Started with 20161122030216 build. Possible regression range: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=b7f895c1dc2e91530240efbf50ac063a0f8a9cb5&tochange=0534254e9a40b4bade2577c631fe4cfa0b5db41d

Not sure if Bug 1309516 has anything to do with the crash. ni on kaku
Flags: needinfo?(kaku)
See Also: → 1319900
Comment on attachment 8813967 [details]
Bug 1319790 - add assertions to detect if MediaDecoder is deleted without Shutdown() being called.

https://reviewboard.mozilla.org/r/95272/#review95450
Attachment #8813967 - Flags: review?(kaku) → review+
Pushed by jwwang@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/65643222e76c
add assertions to detect if MediaDecoder is deleted without Shutdown() being called. r=kaku
Bug 1309516 is unlikely related to this issue, however, will keep an eye on this.
Flags: needinfo?(kaku)
See Also: → 1332146
Bug 1332544 should've fixed this.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1332544
Removing leave-open keyword from resolved bugs, per :sylvestre.
Keywords: leave-open
You need to log in before you can comment on or make changes to this bug.