[stage][prod] SeaMonkey: filtering on `current versions` returns errors

RESOLVED FIXED

Status

RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: mbrandt, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

2 years ago
Several of the automated checks are failing on reports when the products is set as `SeaMonkey` and versions is set to `Current Versions.`

Steps to reproduce:
1. goto crash-stats; set product to SeaMonkey and version to Current Versions
2. Select the Crashes Per Day report.

Actual:
https://crash-stats.allizom.org/home/product/SeaMonkey returns a HTTP 400
https://crash-stats.allizom.org/crashes-per-day/?p=SeaMonkey returns a HTTP 500
Looks like they both fall under the same exception, which is:

RequiredParameterError: versions
  File "django/core/handlers/base.py", line 132, in get_response
    response = wrapped_callback(request, *callback_args, **callback_kwargs)
  File "newrelic/hooks/framework_django.py", line 499, in wrapper
    return wrapped(*args, **kwargs)
  File "crashstats/crashstats/decorators.py", line 101, in inner
    return view(request, *args, **kwargs)
  File "crashstats/crashstats/views.py", line 962, in crashes_per_day
    _date_range_type
  File "crashstats/crashstats/views.py", line 215, in _get_crashes_per_day_with_adu
    platforms=[x['name'] for x in platforms if x.get('display')],
  File "crashstats/crashstats/models.py", line 464, in get
    return self._get(expect_json=expect_json, **kwargs)
  File "crashstats/crashstats/models.py", line 521, in _get
    params = self.kwargs_to_params(kwargs)
  File "crashstats/crashstats/models.py", line 569, in kwargs_to_params
    raise RequiredParameterError(name)

https://sentry.prod.mozaws.net/operations/socorro-stage/issues/332495/
Summary: [stage][prod] Fennec: filtering on `current versions` returns errors → [stage][prod] SeaMonkey: filtering on `current versions` returns errors
I think this is due to SeaMonkey not having any featured version at the moment on stage or prod. I've set the 2 versions we know as featured on stage, waiting for cache to refresh to confirm.
I confirm that it works now that there are featured versions. I've done the same on prod. 

I think we should maybe ensure that there are always featured versions for a product? Peter, what do you think?
Flags: needinfo?(peterbe)
(Reporter)

Comment 5

2 years ago
:adrian - thank you for the immediate fix, the tests are passing again.
Can we not just make the Crashes per Day use the, say, top 4 versions if there are 0 featured versions? I can't think of any better way to "fake" featured versions.
Flags: needinfo?(peterbe)
(Reporter)

Comment 7

2 years ago
Bumping this to resolved. Featured versions are present again.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.