https://omroep-west.now.sh/ is not getting correct Response.json() results

RESOLVED INVALID

Status

()

RESOLVED INVALID
2 years ago
2 years ago

People

(Reporter: bkelly, Assigned: bkelly)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Assignee)

Description

2 years ago
I have a particular FF51 profile that is failing to load this site:

  https://omroep-west.now.sh/

Its dying when trying to parse json results from a fetch() call.  Devtools suggests that the json is fine, however.  If I execute the same code in the web console I get the json fine.  It seems there is some race causing it to fail during the page load.

I cannot reproduce in other profiles even on the same FF51 binary.  I'm saving off my profile to investigate.
(Assignee)

Comment 1

2 years ago
It appears that the site was actually pulling the value out of Cache API.  Once I wiped storage for the site so it pulled from the network again it started work.  I think maybe there is a bug in how the site generates its data and I just happened to persist a bad value.
(Assignee)

Comment 2

2 years ago
Site author confirms its a bug in the site.
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.