Cmd+Q not working / Application Menu empty

VERIFIED FIXED in Firefox 53

Status

()

defect
P1
normal
VERIFIED FIXED
3 years ago
2 years ago

People

(Reporter: mstange, Assigned: spohl)

Tracking

({regression})

Trunk
mozilla53
All
macOS
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox50 unaffected, firefox51 unaffected, firefox52 unaffected, firefox-esr52 unaffected, firefox53+ fixed)

Details

Attachments

(1 attachment)

Steps to reproduce:
 1. Open a new window using Cmd+N.
 2. Close this window.
 3. Click "Nightly" in the menubar to open the application menu.
 4. Wait for about 10 seconds until the old window gets GC'ed.

Expected results:
The menu should stay popuplated.

Actual results:
The menu goes blank after a short time.
In step 2, I mean "close the newly opened window again."
I was just about to file this, thanks for filing Markus.

Tracking 53+ for this visible regression.
Assignee: nobody → spohl.mozilla.bugs
Posted patch PatchSplinter Review
This reverts changeset 6d906f5908d1 (bug 1292527) to restore functionality. Will reopen bug 1292527 to implement this in a way that avoids this bug. Marking as r+ since this is a straight backout with no conflicts.
Attachment #8814085 - Flags: review+
Duplicate of this bug: 1320299
https://hg.mozilla.org/mozilla-central/rev/49228a69b071
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla53
Duplicate of this bug: 1320648
Duplicate of this bug: 1320376
QA Whiteboard: [good first verify]
I have reproduced this bug with Firefox nightly  53.0a1(build id:20161123030208)on
windows 7(64 bit)

I have verified this bug as fixed with Firefox beta 53.0b5 (build id:20170320143328)
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:53.0) Gecko/20100101 Firefox/53.0

[bugday-20170322]
Awesome, thanks for the verification Kazi :)
Status: RESOLVED → VERIFIED
This is a MacOS-specific issue, so this needs to be verified on Mac.
Status: VERIFIED → RESOLVED
Closed: 3 years ago2 years ago
(In reply to Stefan [:stefanh] from comment #11)
> This is a MacOS-specific issue, so this needs to be verified on Mac.

Went through verification using the STR from comment#0 using the following builds under macOS 10.12.3 x64:
* fx53.0b7, buildid: 20170327081421, changeset: 46d5fe92c82d
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.