Closed Bug 1320006 Opened 3 years ago Closed 3 years ago

Android local build failure after bug 1319345

Categories

(Firefox Build System :: General, defect)

defect
Not set

Tracking

(firefox53 fixed)

RESOLVED FIXED
mozilla53
Tracking Status
firefox53 --- fixed

People

(Reporter: JamesCheng, Assigned: glandium)

References

Details

Attachments

(2 files)

I don't know why this may happen on my machine only... I ask other people to test but they don't meet this error.

The attachment is the log by "mach build -v"

I can build success without the patch by bug 1319351.
As said on irc, this can't be attributed to bug 1319351, and considering the build log, bug 1319345 is the only plausible explanation.
Blocks: 1319345
Assignee: nobody → mh+mozilla
Summary: Meet build error when Bug 1319351 is landed. → Android local build failure after bug 1319345
This patch works for me. 

Thanks.

I should do "git bisect" and clobber it every time I do "mach build"...

I didn't, so the git bisect result points to the wrong revision.
Duplicate of this bug: 1320184
Comment on attachment 8813978 [details]
Bug 1320006 - Shell-quote the flags used for file_generate commands.

https://reviewboard.mozilla.org/r/95280/#review95998
Attachment #8813978 - Flags: review?(mshal) → review+
This is busting `date` since today's merge from m-c (merges happen by me, on the same rev as the m-c nightly) -- so the earlier you can land this the better (so it can reach m-c in time for tomorrows nightly).

Thank You.
Flags: needinfo?(mh+mozilla)
Pushed by mh@glandium.org:
https://hg.mozilla.org/integration/autoland/rev/758c23c92f08
Shell-quote the flags used for file_generate commands. r=mshal
Flags: needinfo?(mh+mozilla)
https://hg.mozilla.org/mozilla-central/rev/758c23c92f08
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla53
Duplicate of this bug: 1320978
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.