Closed Bug 1320027 Opened 3 years ago Closed Last year

Crash in IPCError-browser | IndexedDB CheckPermission 1

Categories

(Core :: DOM: IndexedDB, defect, P2, critical)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1450160
Tracking Status
firefox57 --- affected
firefox58 --- affected
firefox59 --- affected

People

(Reporter: kanru, Unassigned)

References

Details

(Keywords: crash)

Crash Data

Priority: -- → P3
Nightly 58 x64 20171013100112 de_DE @ Debian Testing
I couldn't open those per-message menus on https://web.whatsapp.com in one chat (the largest I have) anymore, but in all other chats. I reset every pref I had, deleted cookies, website data and serviceworkers and it didn't help. But it worked in a fresh profile. Then I went back to my main profile and set dom.indexedDB.enabled;false and reloaded whatsapp and got this crash.
bp-1dc91e15-81e3-480b-99e6-a947d0171014	14.10.17 03:03
bp-5f676e16-da23-42e1-8f32-6e56b0171014	14.10.17 03:03
bp-90941cfa-d372-4c04-97c0-718390171014	14.10.17 02:59
bp-3b212958-b54e-4413-a0ad-e680d0171014	14.10.17 02:58
bp-9aadf026-2557-4ac0-a914-04d5a0171014	14.10.17 02:58
OS: Windows 8 → All
Hardware: Unspecified → All
this signature is spiking up in the past few days across channels with many comments referring to youtube as source of the crash.
I got this since Dec. 05th
Only for youtube, on Linux and Windows.
Using µBlock on both machines.

one crash report from Windows:
https://crash-stats.mozilla.com/report/index/e5629ff6-87d5-458b-93a5-cb3620171210
I also am consistently getting this bug when visiting the youtube homepage.

Looks like there is a massive spike in occurrences of this bug since early December.
I just deinstalled FF and then reinstalled it -> crash occurs again for yt
deleting my ~/.mozilla directory was the solution
I made a bug report which seems to match this error - Firefox about:config option for "dom.indexedDB.enabled" set to False.

However, sites (such as Youtube) are still creating the directory and some files for their sites.. I had to manually disallow write access to the site-data folder for Youtube, which fixed the crashes since now Firefox can't write ANYTHING to that folder.
Duplicate of this bug: 1430093
Jan, can you take a look at this crash or help find someone who can investigate? Thanks!
Flags: needinfo?(jvarga)
Andrew can you take a look at this?
Flags: needinfo?(jvarga) → needinfo?(bugmail)
Priority: P3 → P2
Luckily, I already diagnosed this in https://bugzilla.mozilla.org/show_bug.cgi?id=1450160#c5 which you already assigned to :bkelly ;)

(Crash signature is already on that bug.)
Status: NEW → RESOLVED
Closed: Last year
Flags: needinfo?(bugmail)
Resolution: --- → DUPLICATE
Duplicate of bug: 1450160
You need to log in before you can comment on or make changes to this bug.