All users were logged out of Bugzilla on October 13th, 2018

Delete in standalone msg window doesn't advance to next message

VERIFIED DUPLICATE of bug 131769

Status

P2
critical
VERIFIED DUPLICATE of bug 131769
17 years ago
14 years ago

People

(Reporter: mikepinkerton, Assigned: sspitzer)

Tracking

({regression})

Trunk
mozilla1.0
regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
osx debug mozilla build from 3/18/02

-open message in standalone window
-click delete button

expected:
- msg deletes and advances to next unread message, or closes

actual:
- msg deletes.

this makes reading mail a pain in the butt.
(Reporter)

Updated

17 years ago
Keywords: mozilla1.0, nsbeta1, regression

Updated

17 years ago
Keywords: nsbeta1 → nsbeta1+
Priority: -- → P2
Target Milestone: --- → mozilla1.0

Comment 1

17 years ago
Request for close standalone window on delete is bug 80574.
In many other bugs on this subject, navigation is discussed but has never been
decided upon.
Severity: critical → normal
QA Contact: esther → sheelar
(Reporter)

Comment 2

17 years ago
laurel, what you are missing is that this worked fine 2 days ago. this is a 
regression of perfectly functional code.
Severity: normal → critical

Comment 3

17 years ago
Right, sorry for the oversight. 
OS: MacOS X → All
Hardware: Macintosh → All
accepting.

cc ssu and bienvenu, active hackers.
Status: NEW → ASSIGNED
I can reproduce this.  my gut (in its infinite wisdom, and size, as bienvenu 
likes to point out) says this regression is caused by ssu's recent changes.

Comment 6

17 years ago
Although it certainly pays to listen to Seth's gut, I have a feeling that I may
have broken this - it works in my tree, which has a couple of fixes that I
haven't checked in yet.
I'm seeing that in messageWindow.js, gCurrentMessageIsDeleted is false, in 
HandleDeleteOrMoveMsgCompleted()
I'm debugging OnItemRemoved() in messageWindow.js now.

That's where gCurrentMessageIsDeleted should get set to true.
it looks like OnItemRemoved() never gets called.
my apologies to pointing the finger at ssu.  

It's really a dup of #131769, bienvenu has a fix.

I tested it, and the patch in that bug fixes this problem.

*** This bug has been marked as a duplicate of 131769 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Updated

17 years ago
QA Contact: sheelar → laurel

Comment 11

17 years ago
verified OK mar 26 commercial trunk: win98, mac OS 9.2, linux rh6.2
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.