Browser Crash when a developer use .jpg file as favicom

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
2 years ago
3 months ago

People

(Reporter: subash.bhu777, Unassigned, NeedInfo)

Tracking

53 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Android 4.2.2; Mobile; rv:49.0) Gecko/49.0 Firefox/49.0
Build ID: 20161019165725

Steps to reproduce:

To produce the bug, one should add a .jpg image as favicon and put it into the web directory from which mozzilla imports the favicon image.


Actual results:

The browser suddenly stops working and pause for about 5 seconds and crashes. The form data and user data can be lost from this type of bugs


Expected results:

The browser should have worked normally either by rejecting the favicon or should have compressed the image to fit into the site's favicon area.
Created attachment 8816339 [details]
1320220.zip

Works for me with this basic test case. Please provide a website URL where this is an issue.
Flags: needinfo?(subash.bhu777)

Comment 2

3 months ago
Due to the lack of additional info, I'll close this issue as WFM. If the reporter or someone else think to reopen the issue and come with additional info, Please feel free to do it, thanks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.