column settings for unread message count in folder pane not followed

VERIFIED FIXED

Status

VERIFIED FIXED
17 years ago
14 years ago

People

(Reporter: granrosebugs, Assigned: shliang)

Tracking

({regression})

Trunk
x86
Windows 98
regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [adt2 rtm])

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
I'm running 2002031803 on win98.  When I start mail I have an extra unread
message count next in parens next to the folder name in my folder pane.  I have
to click the column selector over the scrollbar and deselect unread and then
reselect it in order for the unread count to disappear and just show the unread
count next to the total.  When I exit the program and restart it, the extra
unread message count shows back up again.

Expected behaviour: the unread message count in parens doesn't show up when the
unread message count column is selected to display.

Updated

17 years ago
QA Contact: esther → olgam

Comment 1

17 years ago
Today's build, Win2K. I worked on existing and new profile in order to follow
Jon's steps, but got little bit different ones. By default Unread and Total in
the Folder pane are off. So we have expected number in parenthesis next to
Folder pane. Select Unread column in the column picker on the Folder pane.
Number in parenthesis next to a Folder disappeared as expected. Close and open
Mail. Now you see extra number in parenthesis next to a Folder AND the same
number in Unread column.
To my opinion, it is better to change the summary: extra info about not read
messages in the Folder pane after closing and re-opening mail. Jon, comments?
(Reporter)

Comment 2

17 years ago
whatever summary makes the most sense as long as the bug gets fixed. ;-)

I just upgraded to 2002040203 and still have the same problem every time I start
mail: unread count in parens, unread count in the unread column, and total count
in the total column.

adding regression keyword since it didn't used to do this.
Keywords: regression

Comment 3

17 years ago
I will attach a screenshot. As mentioned above, the problem goes away if you
deselect 'unread' and then reselect it (by clicking the column selector), but
only until you restart mail&news.

I find this bug is rather disturbing because it's nearly impossible to identify
the names of the newsgroups I subscribed (-> screenshot).

I would be very glad if it's fixed soon.

Comment 4

17 years ago
Created attachment 78912 [details]
Screenshot

Updated

17 years ago
Keywords: nsbeta1+
Whiteboard: [adt2]
(Assignee)

Comment 5

17 years ago
taking
Assignee: sspitzer → shliang
(Assignee)

Comment 6

17 years ago
Created attachment 79693 [details] [diff] [review]
patch
Comment on attachment 79693 [details] [diff] [review]
patch

sr=sspitzer

thanks shuehan.
Attachment #79693 - Flags: superreview+

Comment 8

17 years ago
Comment on attachment 79693 [details] [diff] [review]
patch

r=bhuvan
Attachment #79693 - Flags: review+
(Assignee)

Updated

17 years ago
Keywords: adt1.0.0

Comment 9

17 years ago
please land this on the trunk and get it tested.  Then update the bug with the
results.
Comment on attachment 79693 [details] [diff] [review]
patch

a=asa (on behalf of drivers) for checkin to the 1.0 branch
Attachment #79693 - Flags: approval+

Comment 11

17 years ago
adding adt1.0.0-.  Let's try to get this into RTM.
Keywords: adt1.0.0 → adt1.0.0-
Whiteboard: [adt2] → [adt2 rtm]
(Assignee)

Comment 12

17 years ago
fixed in trunk
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 13

17 years ago
 Verified on trunk build at 04/22/02 on Linux, Win2K, Mac 10.1.3. 
Status: RESOLVED → VERIFIED
(Reporter)

Comment 14

17 years ago
this is adt1.0.0- but nsbeta1+ so will this land on the mozilla 1.0 branch in
the near future?  It would be nice to have this fixed for mozilla 1.0, adding
mozilla1.0 keyword.
Keywords: mozilla1.0

Comment 15

17 years ago
renominating.
Keywords: adt1.0.0- → adt1.0.0
adt1.0.0+ (on ADT's behalf) for approval to checkin to the 1.0 branch.  Please
get drivers a= again, since their previous approval is more than 3 days old. 
After, checking in, please add the fixed1.0 keyword.
Keywords: adt1.0.0 → adt1.0.0+

Comment 17

17 years ago
Sorry if this is a unnecessary comment, but will this fix now go into 1.0.0
automatically? If not, can somebody please do the necessary steps?

Comment 18

17 years ago
Once it gets drivers approval it should be able to land.

Comment 19

17 years ago
changing to adt1.0.1+ for checkin to the 1.0 branch.  Please get drivers
approval before checking in.
Keywords: adt1.0.0+ → adt1.0.1+

Updated

17 years ago
Keywords: mozilla1.0.1
Comment on attachment 79693 [details] [diff] [review]
patch

re-approval for branch

Please land this on the 1.0.1 branch.  Once there, remove the
"mozilla1.0.1+" keyword, and add the "fixed1.0.1"
(Assignee)

Comment 21

17 years ago
checked into branch
Keywords: mozilla1.0.1+ → fixed1.0.1

Comment 22

17 years ago
Verified on 06/14/02 branch build, Win2K, Linux.
Keywords: fixed1.0.1 → verified1.0.1
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.