Last Comment Bug 1320345 - Media content doesn't loading throws getUserMedia error: NotFoundError
: Media content doesn't loading throws getUserMedia error: NotFoundError
Status: RESOLVED INVALID
[testday-20161125][needinfo 2016/12/1...
:
Product: Core
Classification: Components
Component: WebRTC: Audio/Video (show other bugs)
: 51 Branch
: x86_64 Windows 8.1
-- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Maire Reavy [:mreavy] Please needinfo me
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-11-25 08:20 PST by sgovind2112
Modified: 2016-12-17 14:00 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
getUserMediaError.PNG (30.80 KB, image/png)
2016-11-25 08:20 PST, sgovind2112
no flags Details
Loaded the URL https://webrtc.github.io/samples/src/content/peerconnection/pc1/ and clicked start showed pop up alert. (91.45 KB, image/png)
2016-11-25 19:35 PST, sgovind2112
no flags Details

Description User image sgovind2112 2016-11-25 08:20:16 PST
Created attachment 8814448 [details]
getUserMediaError.PNG

User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID: 20161124073320

Steps to reproduce:

I was testing the features in firefox 51 beta version 3 during testday 20161125. When I encountered Indicator to device permission test case 2 and loaded the URL https://webrtc.github.io/samples/src/content/getusermedia/gum/ in the instruction.


Actual results:

The web page loaded but the media content doesn't and it throws getUserMedia: NotFoundError.


Expected results:

The media content should have loaded instead of the error message
Comment 1 User image sgovind2112 2016-11-25 19:35:06 PST
Created attachment 8814527 [details]
Loaded the URL https://webrtc.github.io/samples/src/content/peerconnection/pc1/ and clicked start showed pop up alert.
Comment 2 User image Subhrajyoti Sen 2016-11-25 19:57:59 PST
I was unable to re-produce this bug.

Build ID 	20161124073320
User Agent 	Mozilla/5.0 (X11; Linux x86_64; rv:51.0) Gecko/20100101 Firefox/51.0
Comment 3 User image sgovind2112 2016-11-26 07:02:27 PST
Due to this bug, during testing the device permission didn't show any notification and the i icon in the address bar doesn't change to respective icon. Like if it is video content the icon should change to camera but it doesn't.
Comment 4 User image Andreas Pehrson [:pehrsons] (Telenor) 2016-12-17 02:22:47 PST
When this happened, could you access the camera and microphone in other applications, like Chrome or Skype? 

Did your machine have both a camera and microphone installed?

It sounds like the application requests both audio and video but your machine doesn't have both available. Then this is expected behavior and it's up to the application to fall back to audio or video only. Chrome's behavior might differ but we are following the spec on this.
Comment 5 User image sgovind2112 2016-12-17 08:15:39 PST
I don't have a camera and microphone installed on my machine, Andreas.
Comment 6 User image Randell Jesup [:jesup] 2016-12-17 14:00:08 PST
Working per spec - the webrtc.github examples don't handle spec-compliant gUM failure properly.  :-(

Note You need to log in before you can comment on or make changes to this bug.