Closed Bug 1320386 Opened 3 years ago Closed 3 years ago

Crash in igd10umd64.dll | CVideoProcessor::Blt

Categories

(Core :: Audio/Video: Playback, defect, critical)

49 Branch
Unspecified
Windows
defect
Not set
critical

Tracking

()

RESOLVED FIXED
mozilla53
Tracking Status
firefox50 --- wontfix
firefox51 --- fixed
firefox52 --- fixed
firefox53 --- fixed

People

(Reporter: marco, Assigned: marco)

References

Details

(Keywords: crash, regression)

Crash Data

Attachments

(2 files)

This bug was filed from the Socorro interface and is 
report bp-f7e7257d-2398-4509-9711-8b4562161125.
=============================================================

All the crashes with this signature have driver version 9.17.10.2857.

This driver version is blocked in 32-bit builds, but not in 64-bit ones: https://dxr.mozilla.org/mozilla-central/rev/0ddfec7126ec503b54df9c4b7c3b988906f6c882/modules/libpref/init/all.js#362.
Attached patch PatchSplinter Review
Assignee: nobody → mcastelluccio
Status: NEW → ASSIGNED
Attachment #8814494 - Flags: review?(gsquelart)
Comment on attachment 8814494 [details] [diff] [review]
Patch

Review of attachment 8814494 [details] [diff] [review]:
-----------------------------------------------------------------

Thank you.
Attachment #8814494 - Flags: review?(gsquelart) → review+
Pushed by mcastelluccio@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/f24049bdb047
Block D3D11 for the 64-bit version of the 9.17.10.2857 driver. r=gerald
https://hg.mozilla.org/mozilla-central/rev/f24049bdb047
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla53
Hi Marco,
Is this worth uplifting to Beta51 & Aurora52?
Flags: needinfo?(mcastelluccio)
It is a low volume crash (45 crashes [450 if you consider throttling] in the past week on the release channel), but the fix is really simple (just adding a new entry to the hardware acceleration blocklist) and safe (the entry added to the blocklist was already there for 32 bit builds, but not for 64 bit ones).
It only affects Firefox 64 bit.
Flags: needinfo?(mcastelluccio)
Hi Marco,
Can you create uplift request for Beta51 & Aurora52?
Comment on attachment 8814494 [details] [diff] [review]
Patch

Approval Request Comment
[Feature/Bug causing the regression]: D3D11 DXVA
[User impact if declined]: Users with the Intel driver that is being added to the blocklist might crash while playing videos, on 64 bit builds.
[Is this code covered by automated tests?]: I would expect the blocklist code itself to be covered by automated tests, although I'm not sure.
[Has the fix been verified in Nightly?]: The crash is too low volume on Nightly too tell, but so far we haven't seen any crashes with this signature since the landing.
[Needs manual test from QE? If yes, steps to reproduce]: No.
[List of other uplifts needed for the feature/fix]: None.
[Is the change risky?]: No.
[Why is the change risky/not risky?]: The change is adding a Intel driver to the blocklist that is already there for the 32 bit build, but not for the 64 bit one.
[String changes made/needed]: None.
Attachment #8814494 - Flags: approval-mozilla-beta?
Attachment #8814494 - Flags: approval-mozilla-aurora?
Comment on attachment 8814494 [details] [diff] [review]
Patch

Add a Intel driver to the blocklist. Beta51+ & Aurora52+. Should be in 51 beta 10.
Attachment #8814494 - Flags: approval-mozilla-beta?
Attachment #8814494 - Flags: approval-mozilla-beta+
Attachment #8814494 - Flags: approval-mozilla-aurora?
Attachment #8814494 - Flags: approval-mozilla-aurora+
Attached patch Patch for BetaSplinter Review
The first patch applies cleanly to Aurora, this is the patch for Beta.
Keywords: regression
You need to log in before you can comment on or make changes to this bug.