The default bug view has changed. See this FAQ.

Buttons disabled after refreshing on WebRTC peer connection sample

RESOLVED DUPLICATE of bug 654072

Status

()

Core
WebRTC
RESOLVED DUPLICATE of bug 654072
4 months ago
4 months ago

People

(Reporter: Subhrajyoti Sen, Unassigned)

Tracking

51 Branch
x86_64
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [testday-20161125])

Attachments

(1 attachment)

(Reporter)

Description

4 months ago
Created attachment 8814530 [details]
firefox.png

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID: 20161124073320

Steps to reproduce:

1. Open the following URL
      https://webrtc.github.io/samples/src/content/peerconnection/pc1/
2. Click on Start
3. Click Share Selected Devices in permissions
4. Click Call
5. Click Hang Up
6. Refresh page



Actual results:

All the 3 buttons ( Start, Call, Hang Up) are diabled



Expected results:

Start button should be clickable and should ask for the required permissions
(Reporter)

Updated

4 months ago
OS: Unspecified → Linux
Hardware: Unspecified → x86_64

Updated

4 months ago
Component: Untriaged → WebRTC
Product: Firefox → Core
Workaround: Click on the URL bar and press enter.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All

Comment 2

4 months ago
Dupe of bug 1320615?
No, I have noticed this before, I am not sure if it is a problem or something else. I will ask later on IRC when everyone is on board.
Whiteboard: [testday-20161125]
Known issue.  The JS code should explicitly set the disable state when it sets the default state of the other buttons.
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 654072
You need to log in before you can comment on or make changes to this bug.