Closed Bug 1320423 Opened 3 years ago Closed 3 years ago

Crash in nsFrame::FillCursorInformationFromStyle

Categories

(Core :: CSS Parsing and Computation, defect, critical)

defect
Not set
critical

Tracking

()

RESOLVED FIXED
mozilla53
Tracking Status
firefox51 --- unaffected
firefox52 --- unaffected
firefox53 --- fixed

People

(Reporter: jchen, Assigned: heycam)

References

Details

(Keywords: crash)

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is 
report bp-5c6a1d25-a3da-4687-b5f9-74c3c2161123.
=============================================================

Low volume crash that first appeared in the 11-22 Nightly with a single crash on Windows, but has since had 11 crashes for 11-23, 8 for 11-24, and 7 for 11-25 (#21 top crash). The 11-22 crash looks normal, so assuming a regression from 11-22 and looking at the regression range [1], I see bug 1310560 as a possible source since it dealt with cursors. Can you take a look, Cameron?

[1] https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=b7f895c1dc2e91530240efbf50ac063a0f8a9cb5&tochange=0534254e9a40b4bade2577c631fe4cfa0b5db41d
Flags: needinfo?(cam)
Component: Layout → CSS Parsing and Computation
Thanks.  I probably forgot to add some null checks for cursors, now that we store an nsStyleImageRequest even for a failed URL load (but whose GetImageValue() returns null).
Assignee: nobody → cam
Status: NEW → ASSIGNED
Flags: needinfo?(cam)
55 crashes from 18 installations in the past 7 days, so it's more medium-volume.
Comment on attachment 8814539 [details]
Bug 1320423 - Null check cursor images to handled failed loads.

https://reviewboard.mozilla.org/r/95748/#review95878
Attachment #8814539 - Flags: review?(dbaron) → review+
Pushed by cmccormack@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ce2b35bf0048
Null check cursor images to handled failed loads. r=dbaron
https://hg.mozilla.org/mozilla-central/rev/ce2b35bf0048
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla53
You need to log in before you can comment on or make changes to this bug.