Crash when browsing a website with a Google map (ABORT: X_ShmAttach: BadAccess)

RESOLVED DUPLICATE of bug 1271100

Status

()

--
critical
RESOLVED DUPLICATE of bug 1271100
2 years ago
a year ago

People

(Reporter: oscar.stefanini, Unassigned)

Tracking

({crash})

50 Branch
x86_64
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID: 20161114144856

Steps to reproduce:

I just go on some page with a google map, like on this page: http://www.isatech.fr/isatech/notre-societe/ when i zoom/dezoomm (on desktop, ubuntu 16.10)


Actual results:

firefox abort

Comment 1

2 years ago
Dupe of bug 1302974?

Can you open about:support and copy the graphics section. Do you have crash reports (bp-...) in about:crashes?
Severity: normal → critical
Flags: needinfo?(oscar.stefanini)
Keywords: crash
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
Summary: google map → Crash when browsing a website with a Google map
(Reporter)

Comment 2

2 years ago
Yep, I will add it tonight if I remember. It doest not appear on windows 10 with forefox 50.0
(Reporter)

Comment 3

2 years ago
Okay, I am nit sure you
(Reporter)

Comment 4

2 years ago
I am not sure you are looking for this, But this is the result of the abort: AbortMessage: ###!!! ABORT: X_ShmAttach: BadAccess (attempt to access private resource denied); 14 requests ago: file /build/firefox-wm7CB0/firefox-50.0+build2/toolkit/xre/nsX11ErrorHandler.cpp, line 147
Add-ons: ubufox%40ubuntu.com:3.2,%7B972ce4c6-7e08-4474-a285-3208198ce6fd%7D:50.0,firefox%40getpocket.com:1.0.5,webcompat%40mozilla.org:1.0,e10srollout%40mozilla.org:1.5,aushelper%40mozilla.org:1.0,langpack-en-GB%40firefox.mozilla.org:50.0,langpack-fr%40firefox.mozilla.org:50.0,langpack-en-ZA%40firefox.mozilla.org:50.0
AddonsShouldHaveBlockedE10s: 1
BuildID: 20161114144856
ContentSandboxCapabilities: 117
CrashTime: 1480578943
E10SCohort: disqualified-test
EMCheckCompatibility: true
EventLoopNestingLevel: 1
FramePoisonBase: 7ffffffff0dea000
FramePoisonSize: 4096
InstallTime: 1479676699
Notes: OpenGL: Intel Open Source Technology Center -- Mesa DRI Intel(R) HD Graphics 5500 (Broadwell GT2)  -- 3.0 Mesa 12.0.3 -- texture_from_pixmap
FP(D000-L10000-W00000000-T0000) X_ShmAttach: BadAccess (attempt to access private resource denied); 14 requests agoxpcom_runtime_abort(###!!! ABORT: X_ShmAttach: BadAccess (attempt to access private resource denied); 14 requests ago: file /build/firefox-wm7CB0/firefox-50.0+build2/toolkit/xre/nsX11ErrorHandler.cpp, line 147)
ProductID: {ec8030f7-c20a-464f-9b0e-13a3a9e97384}
ProductName: Firefox
ReleaseChannel: release
SafeMode: 0
SecondsSinceLastCrash: 410075
StartupTime: 1480578894
TelemetryEnvironment: {"build":{"applicationId":"{ec8030f7-c20a-464f-9b0e-13a3a9e97384}","applicationName":"Firefox","architecture":"x86-64","buildId":"20161114144856","version":"50.0","vendor":"Mozilla","platformVersion":"50.0","xpcomAbi":"x86_64-gcc3","hotfixVersion":"20160826.01"},"partner":{"distributionId":"canonical","distributionVersion":"1.0","partnerId":null,"distributor":null,"distributorChannel":null,"partnerNames":["ubuntu "]},"system":{"memoryMB":7858,"virtualMaxMB":null,"cpu":{"count":4,"cores":2,"vendor":"GenuineIntel","family":6,"model":61,"stepping":4,"l2cacheKB":256,"l3cacheKB":4096,"speedMHz":3200,"extensions":["hasMMX","hasSSE","hasSSE2","hasSSE3","hasSSSE3","hasSSE4_1","hasSSE4_2","hasAVX","hasAVX2"]},"os":{"name":"Linux","version":"4.8.0-26-generic","locale":"fr-FR"},"hdd":{"profile":{"model":null,"revision":null},"binary":{"model":null,"revision":null},"system":{"model":null,"revision":null}},"gfx":{"D2DEnabled":null,"DWriteEnabled":null,"adapters":[{"description":"Intel Open Source Technology Center -- Mesa DRI Intel(R) HD Graphics 5500 (Broadwell GT2) ","vendorID":"Intel Open Source Technology Center","deviceID":"Mesa DRI Intel(R) HD Graphics 5500 (Broadwell GT2) ","subsysID":null,"RAM":null,"driver":null,"driverVersion":"3.0 Mesa 12.0.3","driverDate":null,"GPUActive":true}],"monitors":[],"features":{"compositor":"basic"}}},"settings":{"blocklistEnabled":true,"e10sEnabled":false,"e10sCohort":"disqualified-test","telemetryEnabled":false,"locale":"fr","update":{"channel":"release","enabled":true,"autoDownload":true},"userPrefs":{"browser.cache.disk.capacity":358400,"browser.newtabpage.enhanced":true},"addonCompatibilityCheckEnabled":true,"isDefaultBrowser":false,"defaultSearchEngine":"ddg","defaultSearchEngineData":{"name":"DuckDuckGo","loadPath":"[distribution]/searchplugins/locale/en-US/ddg.xml","origin":"default","submissionURL":"https://duckduckgo.com/?q=&t=canonical"}},"profile":{"creationDate":17095},"addons":{"activeAddons":{"ubufox@ubuntu.com":{"blocklisted":false,"description":"Paquet Firefox Pour Ubuntu.","name":"Ubuntu Modifications","userDisabled":false,"appDisabled":false,"version":"3.2","scope":8,"type":"extension","foreignInstall":true,"hasBinaryComponents":false,"installDay":16696,"updateDay":16696,"signedState":2,"isSystem":false},"firefox@getpocket.com":{"blocklisted":false,"description":"When you find something you want to view later, put it in Pocket.","name":"Pocket","userDisabled":false,"appDisabled":false,"version":"1.0.5","scope":1,"type":"extension","foreignInstall":false,"hasBinaryComponents":false,"installDay":17072,"updateDay":17119,"isSystem":true},"webcompat@mozilla.org":{"blocklisted":false,"description":"Urgent post-release fixes for web compatibility.","name":"Web Compat","userDisabled":false,"appDisabled":false,"version":"1.0","scope":1,"type":"extension","foreignInstall":false,"hasBinaryComponents":false,"installDay":17072,"updateDay":17119,"isSystem":true},"e10srollout@mozilla.org":{"blocklisted":false,"description":"Staged rollout of Firefox multi-process feature.","name":"Multi-process staged rollout","userDisabled":false,"appDisabled":false,"version":"1.5","scope":1,"type":"extension","foreignInstall":false,"hasBinaryComponents":false,"installDay":17072,"updateDay":17119,"isSystem":true},"aushelper@mozilla.org":{"blocklisted":false,"description":"Sets value(s) in the update url based on custom checks.","name":"Application Update Service Helper","userDisabled":false,"appDisabled":false,"version":"1.0","scope":1,"type":"extension","foreignInstall":false,"hasBinaryComponents":false,"installDay":17119,"updateDay":17119,"isSystem":true}},"theme":{"id":"{972ce4c6-7e08-4474-a285-3208198ce6fd}","blocklisted":false,"description":"Le thème par défaut.","name":"Thème par défaut","userDisabled":false,"appDisabled":false,"version":"50.0","scope":4,"foreignInstall":false,"hasBinaryComponents":false,"installDay":17072,"updateDay":17119},"activePlugins":[{"name":"GNOME Shell Integration","version":"","description":"This plugin provides integration with GNOME Shell for live extension enabling and disabling. It can ","blocklisted":false,"disabled":false,"clicktoplay":true,"mimeTypes":["application/x-gnome-shell-integration"],"updateDay":17078},{"name":"Shockwave Flash","version":"11.2.202.644","description":"Shockwave Flash 11.2 r202","blocklisted":false,"disabled":false,"clicktoplay":false,"mimeTypes":["application/x-shockwave-flash","application/futuresplash"],"updateDay":17122}],"activeGMPlugins":{"gmp-gmpopenh264":{"version":"1.6","userDisabled":false,"applyBackgroundUpdates":1},"gmp-widevinecdm":{"version":"1.4.8.903","userDisabled":false,"applyBackgroundUpdates":1}},"activeExperiment":{},"persona":null}}
Theme: classic/1.0
Throttleable: 1
UptimeTS: 54.43229516
Vendor: Mozilla
Version: 50.0
useragent_locale: en-US

This report also contains technical information about the state of the application when it crashed.
Flags: needinfo?(oscar.stefanini)
(Reporter)

Comment 5

2 years ago
(In reply to oscar.stefanini from comment #2)
> Yep, I will add it tonight if I remember. It doest not appear on windows 10
> with forefox 50.0

Comment 6

2 years ago
Are you using the Intel drivers? If not, could you test with them, please.
(Reporter)

Comment 7

2 years ago
I am not sure how to deal with this... how to know wich driver I use ?

Comment 8

2 years ago
Type about:support in the URL bar of Firefox et copy here the "graphics" section.
(Reporter)

Comment 9

2 years ago
 Accélération graphique
Fonctionnalités
Composition	Basic
Zoom/Panoramique asynchrones	aucun
Rendu WebGL	Intel Open Source Technology Center -- Mesa DRI Intel(R) HD Graphics 5500 (Broadwell GT2)
Rendu WebGL2	(no info)
Décodage matériel H264	No
Backend audio	pulse
GPU 1
Actif	Oui
Description	Intel Open Source Technology Center -- Mesa DRI Intel(R) HD Graphics 5500 (Broadwell GT2)
ID du vendeur	Intel Open Source Technology Center
ID du périphérique	Mesa DRI Intel(R) HD Graphics 5500 (Broadwell GT2)
Version du pilote	3.0 Mesa 12.0.3
Diagnostics
AzureCanvasAccelerated	0
AzureCanvasBackend	skia
AzureContentBackend	cairo
AzureFallbackCanvasBackend	none
CairoUseXRender	0
Journal des décisions
HW_COMPOSITING	
blocked by default: Acceleration blocked by platform
OPENGL_COMPOSITING	
unavailable by default: Hardware compositing is disabled

that's ?
(In reply to oscar.stefanini from comment #4)
> AbortMessage: ###!!! ABORT: X_ShmAttach: BadAccess (attempt to access
> private resource denied); 14 requests ago

Sounds a bit like bug 559837?
Component: Untriaged → Graphics
Product: Firefox → Core
Summary: Crash when browsing a website with a Google map → Crash when browsing a website with a Google map (ABORT: X_ShmAttach: BadAccess)

Updated

2 years ago
Blocks: 1320542
Karl, is this X error something we need to handle in some way?
Flags: needinfo?(karlt)
This is probably the same as bug 1271100, which has a fix in 50.1
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(karlt)
Resolution: --- → DUPLICATE
Duplicate of bug: 1271100
You need to log in before you can comment on or make changes to this bug.