Closed Bug 1320554 Opened 3 years ago Closed 3 years ago

keyword not updated after url edit

Categories

(Firefox :: Bookmarks & History, defect, P3, minor)

45 Branch
x86_64
Linux
defect

Tracking

()

RESOLVED DUPLICATE of bug 1150678

People

(Reporter: headset001, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20160921132349

Steps to reproduce:

1. bookmark a page; 
2. edit the bookmark to add a keyword and save; 
3. edit the bookmark to change its Location (URL) and save; 
4. remove the bookmark; 
5. verify with SQLite Manager add-on that the keyword in moz_keywords table in places.sqlite database still has the keyword in it; 
6. in order to remove it, you can create the original bookmark again and delete it. 

This contributes to this problem: https://support.mozilla.org/en-US/questions/1128837 and makes URL changes in bookmarks intended to create a smart keyword from a simple one not feasible.
Severity: normal → minor
Component: Untriaged → Bookmarks & History
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
Priority: -- → P1
Priority: P1 → P3
The bug should be fixed in Firefox 51 (currently Beta)
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1150678
You need to log in before you can comment on or make changes to this bug.