Regression about video performance due to GPU acceleration blacklisted (atiumd64.dll 7.14.10.911) in Firefox 51

RESOLVED WONTFIX

Status

()

Core
Audio/Video: Playback
RESOLVED WONTFIX
a year ago
11 months ago

People

(Reporter: zeusex81, Unassigned, NeedInfo)

Tracking

({regression})

51 Branch
regression
Points:
---

Firefox Tracking Flags

(firefox50 unaffected, firefox51 wontfix)

Details

(Reporter)

Description

a year ago
The "Improved video performance for users without GPU acceleration" update of firefox 51 seems to have the opposite effect on my laptop which is hardware accelerated (I think).
With 50/60 fps video I'm now forced to decrease the quality to 480p to be able to watch them without any freeze and it makes me very sad.
Even my smartphone can do better. :'(

Comment 1

a year ago
Could you type about:support and copy here the section "graphics".
Component: Untriaged → Audio/Video: Playback
Flags: needinfo?(zeusex81)
Product: Firefox → Core
(Reporter)

Comment 2

a year ago
Oh yes I have two differences :
- on FF50 :
Rendu WebGL2	        (no info)
Décodage matériel H264	Yes; Using D3D11 API

- on FF51 :
Rendu WebGL2	        Google Inc. -- ANGLE (ATI Mobility Radeon HD 4500 Series Direct3D11 vs_4_1 ps_4_1)
Décodage matériel H264	No; Failed to create D3D11 device for decoder; D3D9 blacklisted with DLL atiumd64.dll (7.14.10.911)

The complete section : http://i.imgur.com/LT904uE.png

Updated

a year ago
Component: Audio/Video: Playback → Graphics
Summary: firefox 51 video performance regression → Regression about video performance due to GPU acceleration blacklisted (atiumd64.dll 7.14.10.911) in Firefox 51

Updated

a year ago
status-firefox50: --- → unaffected
status-firefox51: --- → affected
Keywords: regression
Hi Peter,
Can you help find someone to investigate this or an owner for this?
Flags: needinfo?(howareyou322)
T(In reply to zeusex81 from comment #2)
> Oh yes I have two differences :
> - on FF50 :
> Rendu WebGL2	        (no info)
> Décodage matériel H264	Yes; Using D3D11 API
> 
> - on FF51 :
> Rendu WebGL2	        Google Inc. -- ANGLE (ATI Mobility Radeon HD 4500
> Series Direct3D11 vs_4_1 ps_4_1)
> Décodage matériel H264	No; Failed to create D3D11 device for decoder; D3D9
> blacklisted with DLL atiumd64.dll (7.14.10.911)
This was blocked beacuse of bug 1265281. Reporter, could you try the following instruction to see any crash or not?

Typing about:config in the latest Firefox, search for "media.wmf.disable-d3d9-for-dlls", double click on the value, and remove 7.14.10.911 from the list and then restart firefox.

> 
> The complete section : http://i.imgur.com/LT904uE.png
Flags: needinfo?(howareyou322)

Updated

a year ago
Blocks: 1265281
(Reporter)

Comment 5

a year ago
(In reply to Peter Chang[:pchang] from comment #4)
> T(In reply to zeusex81 from comment #2)
> > Oh yes I have two differences :
> > - on FF50 :
> > Rendu WebGL2	        (no info)
> > Décodage matériel H264	Yes; Using D3D11 API
> > 
> > - on FF51 :
> > Rendu WebGL2	        Google Inc. -- ANGLE (ATI Mobility Radeon HD 4500
> > Series Direct3D11 vs_4_1 ps_4_1)
> > Décodage matériel H264	No; Failed to create D3D11 device for decoder; D3D9
> > blacklisted with DLL atiumd64.dll (7.14.10.911)
> This was blocked beacuse of bug 1265281. Reporter, could you try the
> following instruction to see any crash or not?
> 
> Typing about:config in the latest Firefox, search for
> "media.wmf.disable-d3d9-for-dlls", double click on the value, and remove
> 7.14.10.911 from the list and then restart firefox.
> 
> > 
> > The complete section : http://i.imgur.com/LT904uE.png

Sure, now the status in about:support is 
Décodage matériel H264	Yes; Failed to create D3D11 device for decoder; Using D3D9 API

It still fails to use D3D11 but it works and the performances are back.
Given comment 5 (saying that it works with d3d9 enabled for this hardware), should un-block this hardware?
Component: Graphics → Audio/Video: Playback
Flags: needinfo?(cpearce)
We disabled that version due to having crashes filed against it. We're making changes in Nightly that should help here; moving graphics into a dedicated process, and moving the video decoding into that process too. We expect the later change to improve crashiness, and we can also be more tolerant of crashy drivers if we have the crash isolated away from the content process. So sit tight, help is on the way.
Flags: needinfo?(cpearce)
Per comment 7, close this bug as WONTFIX in FF51.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → WONTFIX
See Also: → bug 1264543
Per comment #7 & #8, mark 51 as won't fix.
status-firefox51: affected → wontfix
You need to log in before you can comment on or make changes to this bug.